summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2021-11-19 10:02:57 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2021-11-19 10:37:36 +0100
commit9817d48d189873ef705fe2b74ee305681938dfc5 (patch)
tree51f06d85e32b433ae08ed88c0e98eb52b51b28a7 /dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild
parentdev-python/matplotlib: Remove old (diff)
downloadgentoo-9817d48d189873ef705fe2b74ee305681938dfc5.tar.gz
gentoo-9817d48d189873ef705fe2b74ee305681938dfc5.tar.bz2
gentoo-9817d48d189873ef705fe2b74ee305681938dfc5.zip
dev-libs/qtkeychain: 0.13.2 version bump
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild')
-rw-r--r--dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild47
1 files changed, 47 insertions, 0 deletions
diff --git a/dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild b/dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild
new file mode 100644
index 000000000000..3cef787f6509
--- /dev/null
+++ b/dev-libs/qtkeychain/qtkeychain-0.13.2.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake
+
+HOMEPAGE="https://github.com/frankosterfeld/qtkeychain"
+DESCRIPTION="Qt API for storing passwords securely"
+
+if [[ ${PV} != *9999* ]]; then
+ SRC_URI="https://github.com/frankosterfeld/qtkeychain/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~ppc64 ~riscv ~x86"
+else
+ inherit git-r3
+ EGIT_REPO_URI="${HOMEPAGE}.git"
+fi
+
+LICENSE="BSD-2"
+SLOT="0/1"
+IUSE="gnome-keyring"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ gnome-keyring? (
+ app-crypt/libsecret
+ dev-libs/glib:2
+ )
+"
+RDEPEND="${DEPEND}"
+BDEPEND="
+ dev-qt/linguist-tools:5
+"
+
+DOCS=( ChangeLog ReadMe.md )
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_WITH_QT6=OFF
+ -DBUILD_TEST_APPLICATION=OFF
+ -DBUILD_TRANSLATIONS=ON
+ -DLIBSECRET_SUPPORT=$(usex gnome-keyring)
+ )
+
+ cmake_src_configure
+}