summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-02-02 05:52:47 +0000
committerSam James <sam@gentoo.org>2023-02-02 06:26:57 +0000
commitf8cf36e58ab9c3251bda4aef8f9b91c38f63c090 (patch)
treebf2460b20dd59d1d808ca72ad19b69f2ce947eec /dev-libs/rasqal
parentdev-ruby/ox: drop 2.14.10 (diff)
downloadgentoo-f8cf36e58ab9c3251bda4aef8f9b91c38f63c090.tar.gz
gentoo-f8cf36e58ab9c3251bda4aef8f9b91c38f63c090.tar.bz2
gentoo-f8cf36e58ab9c3251bda4aef8f9b91c38f63c090.zip
dev-libs/rasqal: fix configure w/ clang 16
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs/rasqal')
-rw-r--r--dev-libs/rasqal/files/rasqal-0.9.33-configure-clang16.patch22
-rw-r--r--dev-libs/rasqal/rasqal-0.9.33-r1.ebuild (renamed from dev-libs/rasqal/rasqal-0.9.33.ebuild)14
2 files changed, 32 insertions, 4 deletions
diff --git a/dev-libs/rasqal/files/rasqal-0.9.33-configure-clang16.patch b/dev-libs/rasqal/files/rasqal-0.9.33-configure-clang16.patch
new file mode 100644
index 000000000000..1916bdf45d36
--- /dev/null
+++ b/dev-libs/rasqal/files/rasqal-0.9.33-configure-clang16.patch
@@ -0,0 +1,22 @@
+https://github.com/dajobe/rasqal/pull/11
+
+From 2e82a970a8856081a53fc075e6d1534251206810 Mon Sep 17 00:00:00 2001
+From: =?UTF-8?q?Timm=20B=C3=A4der?= <tbaeder@redhat.com>
+Date: Tue, 24 Jan 2023 09:14:02 +0100
+Subject: [PATCH] Define printf() before using it in a configure check
+
+Both clang and GCC will default to treating undefined functions as
+errors in the near future.
+--- a/configure.ac
++++ b/configure.ac
+@@ -313,7 +313,8 @@ AC_C_CONST
+ AC_C_BIGENDIAN
+
+ AC_MSG_CHECKING(whether __FUNCTION__ is available)
+-AC_COMPILE_IFELSE([AC_LANG_SOURCE([int main() { printf(__FUNCTION__); }])],
++AC_COMPILE_IFELSE([AC_LANG_SOURCE([#include <stdio.h>
++ int main() { printf(__FUNCTION__); }])],
+ [AC_DEFINE([HAVE___FUNCTION__], [1], [Is __FUNCTION__ available])
+ AC_MSG_RESULT(yes)],
+ [AC_MSG_RESULT(no)])
+
diff --git a/dev-libs/rasqal/rasqal-0.9.33.ebuild b/dev-libs/rasqal/rasqal-0.9.33-r1.ebuild
index 5c98ab136994..3b56db4ba01c 100644
--- a/dev-libs/rasqal/rasqal-0.9.33.ebuild
+++ b/dev-libs/rasqal/rasqal-0.9.33-r1.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-inherit libtool
+inherit autotools
DESCRIPTION="Library that handles Resource Description Framework (RDF)"
HOMEPAGE="http://librdf.org/rasqal/"
@@ -38,9 +38,15 @@ BDEPEND="
DOCS=( AUTHORS ChangeLog NEWS README )
HTML_DOCS=( {NEWS,README,RELEASE}.html )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.9.33-configure-clang16.patch
+)
+
src_prepare() {
default
- elibtoolize # g/fbsd .so versioning
+
+ #elibtoolize # g/fbsd .so versioning
+ eautoreconf # for clang 16 patch
}
src_configure() {