summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <chutzpah@gentoo.org>2023-01-26 10:43:09 -0800
committerPatrick McLean <chutzpah@gentoo.org>2023-01-26 10:44:54 -0800
commitf01ff5d4fd807f39562aa46c492088692b162e94 (patch)
tree08f384a714eaca1af669224be61f5691177ed074 /dev-libs/simdjson
parentdev-python/towncrier: Stabilize 22.12.0 ALLARCHES, #892101 (diff)
downloadgentoo-f01ff5d4fd807f39562aa46c492088692b162e94.tar.gz
gentoo-f01ff5d4fd807f39562aa46c492088692b162e94.tar.bz2
gentoo-f01ff5d4fd807f39562aa46c492088692b162e94.zip
dev-libs/simdjson: add 3.1.0
Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-libs/simdjson')
-rw-r--r--dev-libs/simdjson/Manifest1
-rw-r--r--dev-libs/simdjson/simdjson-3.1.0.ebuild87
2 files changed, 88 insertions, 0 deletions
diff --git a/dev-libs/simdjson/Manifest b/dev-libs/simdjson/Manifest
index 8789b4d56f14..2327f2d0db37 100644
--- a/dev-libs/simdjson/Manifest
+++ b/dev-libs/simdjson/Manifest
@@ -4,4 +4,5 @@ DIST simdjson-2.0.4.gh.tar.gz 1612055 BLAKE2B af60f4ae6780eb4068ac85c2d6784539b1
DIST simdjson-2.1.0.gh.tar.gz 1618798 BLAKE2B 019e04ae5c5d0e43bf81734edb72d969d95fa4325f2e9aa51258d71587a6d71e4f26edd9beb2797fbf420ee4d7434985e7d960943dacedfab3a6afe616ca20b9 SHA512 6689349195ac4f0f94d47915f90b69663b6a010523fcf58fbe8bb3815db946c65208104c6f1e5d97e42cc1e1b883e5488c059df0afcc7f6e648e2ab3eb97af13
DIST simdjson-2.2.2.gh.tar.gz 1623231 BLAKE2B 1caea4b5224194770af5b43c82110faf9fd17450935af67e3f9e6d3da164ffd3d40a4cca49a4d1b3007549835ecb838b6788e97059548dfa86b206ce240bdbd9 SHA512 a11698491d12aac3b92dae0fd994d0809910cf5c88550058c84035aa3bec02ab4541ab99e12db6605581f6ba61d7951a2cf3988fc20a467f4993f35d24cf2a76
DIST simdjson-3.0.0.gh.tar.gz 1628275 BLAKE2B eef18be927c50527885f6e042ef22317b7e6da6a77d652a4415b98ec7fda227a1b3b798774c12b587a1a011b16c4011a0656f1bf1a20886432796e64076f4775 SHA512 4ea58cd4d059f5e83734f8f084056a58a587529e13df5c47fbb42b141052688f8517ab4e7d6cd4581c6b560f8804968fa0c9c7184b1d8d54e45c280302a069ec
+DIST simdjson-3.1.0.gh.tar.gz 1632837 BLAKE2B c7df7d500753c0fc23637b81e5fa2b01617d1ed24b388054b94cd877d4b9a21cc7495f3a98910600aa9e659a3d734ed6abcc9ba2f6f1f497cbadae313af02d9b SHA512 839b96c17c40274080b2543a78845bae6e7784a53374c0935674e52283ba1cda9dc55ac910641644eb55b8413b02156205153d95619a06ed8bb054429b992051
DIST simdjson-data-a5b13babe65c1bba7186b41b43d4cbdc20a5c470.tar.gz 6635706 BLAKE2B 563376147f18d590a176a5a0398365db1a3e677b773c018f335efa7fff05ac22ac5dc37613792082a32e6c9b91a773a590f7dfd15efa5ba660f9142b128b28a7 SHA512 168198404b11b8c76ff4f53645d7b5a88a5c72b4a5b6646b4410859ec3416ae9b37fc59f7d2f014ccc785615ea5c31dc00b145dbb1a7acb701b94029dd4ea1e1
diff --git a/dev-libs/simdjson/simdjson-3.1.0.ebuild b/dev-libs/simdjson/simdjson-3.1.0.ebuild
new file mode 100644
index 000000000000..8ccb08ef4676
--- /dev/null
+++ b/dev-libs/simdjson/simdjson-3.1.0.ebuild
@@ -0,0 +1,87 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit toolchain-funcs cmake
+
+DATA_HASH="a5b13babe65c1bba7186b41b43d4cbdc20a5c470"
+DESCRIPTION="SIMD accelerated C++ JSON library"
+HOMEPAGE="
+ https://simdjson.org/
+ https://github.com/simdjson/simdjson
+"
+SRC_URI="
+ https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz
+ test? ( https://github.com/${PN}/${PN}-data/archive/${DATA_HASH}.tar.gz -> ${PN}-data-${DATA_HASH}.tar.gz )
+"
+
+LICENSE="Apache-2.0 Boost-1.0 BSD MIT"
+SLOT="0/15"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="test tools"
+
+BDEPEND="
+ sys-apps/file
+ sys-apps/grep
+ virtual/pkgconfig
+"
+DEPEND="
+ tools? ( dev-libs/cxxopts:= )
+"
+
+REQUIRED_USE="test? ( tools )"
+RESTRICT="!test? ( test )"
+
+PATCHES=(
+ "${FILESDIR}/simdjson-1.0.0-dont-bundle-cxxopts.patch"
+ "${FILESDIR}/simdjson-0.9.0-tests.patch"
+ "${FILESDIR}/simdjson-1.0.0-dont-fetch-data-tarball.patch"
+ "${FILESDIR}/simdjson-1.0.0-install-tools.patch"
+ "${FILESDIR}/simdjson-1.0.0-tests.patch"
+)
+
+DOCS=(
+ AUTHORS
+ CONTRIBUTING.md
+ CONTRIBUTORS
+ HACKING.md
+ README.md
+)
+
+src_prepare() {
+ if use test; then
+ mv "${WORKDIR}/${PN}-data-${DATA_HASH}" "${S}/dependencies/${PN}-data" || die
+ fi
+
+ sed -e 's:-Werror ::' -i cmake/developer-options.cmake || die
+ sed -e '/Werror/ d ; /Werror/ d ' -i tests/ondemand/compilation_failure_tests/CMakeLists.txt || die
+ sed -e "s:^c++ :$(tc-getCXX) :" -i singleheader/README.md || die
+ mv tools/{,simd}jsonpointer.cpp || die
+ cmake_src_prepare
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DSIMDJSON_ENABLE_THREADS=ON
+ )
+ use test && mycmakeargs+=(
+ -DSIMDJSON_TESTS=ON
+ )
+
+ if use tools; then
+ mycmakeargs+=(
+ -DSIMDJSON_DEVELOPER_MODE=ON
+ -DSIMDJSON_ALLOW_DOWNLOADS=OFF
+ -DSIMDJSON_GOOGLE_BENCHMARKS=OFF
+ -DSIMDJSON_COMPETITION=OFF
+ -DSIMDJSON_TOOLS=ON
+ )
+ elif ! use test; then
+ mycmakeargs+=(
+ -DSIMDJSON_DEVELOPER_MODE=OFF
+ )
+ fi
+
+ cmake_src_configure
+}