summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2025-02-02 13:02:30 -0500
committerMatt Turner <mattst88@gentoo.org>2025-02-02 13:02:30 -0500
commit96bf63970335c329686030ea3e58c7d0c2a66b53 (patch)
tree0c0ab9b1e93bca296221a3c661ccab14931a3b31 /dev-libs/wayland-protocols
parentwww-servers/xsp: treeclean (diff)
downloadgentoo-96bf63970335c329686030ea3e58c7d0c2a66b53.tar.gz
gentoo-96bf63970335c329686030ea3e58c7d0c2a66b53.tar.bz2
gentoo-96bf63970335c329686030ea3e58c7d0c2a66b53.zip
dev-libs/wayland-protocols: Version bump to 1.40
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs/wayland-protocols')
-rw-r--r--dev-libs/wayland-protocols/Manifest1
-rw-r--r--dev-libs/wayland-protocols/wayland-protocols-1.40.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-libs/wayland-protocols/Manifest b/dev-libs/wayland-protocols/Manifest
index 629dac6ee6bd..008362b605f3 100644
--- a/dev-libs/wayland-protocols/Manifest
+++ b/dev-libs/wayland-protocols/Manifest
@@ -1,2 +1,3 @@
DIST wayland-protocols-1.38.tar.xz 102648 BLAKE2B b07abed74b2f83247f3746414dc1f9e317793f9bc6ae7c1cb955d94149577964dee2ed0d658d4b9d9d7bd446509966393f4060b85db09b56292ddd9702bd1aee SHA512 43fc36d35bedb245deed0e2de246f42d2bbfa6ecafa094f2a7fb103d6df8ae28f3cc200bc5aa24745b9131a28381883c24779da0a6d9ac954753bd5ebb1405db
DIST wayland-protocols-1.39.tar.xz 108844 BLAKE2B ca0350acdce8e2b3803ef4582576fd2db61228f54cebfa232ebbf85377a7201ceb9a96650c8940dc91c193681fa70a0fcb3d5fa9e541acfe77ae07448e998f9d SHA512 480a195ec0846400d93160e3d0a7ba12948ed841835ee4661f54b0101ae0027affd9c0f660a73244786fecd70e4f609830489a6b95e00d750cf2379734aacbe0
+DIST wayland-protocols-1.40.tar.xz 109104 BLAKE2B 48f5540088dd0c7d4c7824f95707c33eceb7d474f4925f7395040f5364dca58c5638e2d2c1c93de7d8c1e41870f6be11d635d1a8b8da496e6ac3a592c02cf143 SHA512 f9bbab39d5df593f292da7bf44e822b53530d47d5ca63ecb0f454680722c4d39ccae2be88ba97a644f79b4a3cce2af111cad2a8f75fdc199f858dc7eda0cf820
diff --git a/dev-libs/wayland-protocols/wayland-protocols-1.40.ebuild b/dev-libs/wayland-protocols/wayland-protocols-1.40.ebuild
new file mode 100644
index 000000000000..88fd7ea8817d
--- /dev/null
+++ b/dev-libs/wayland-protocols/wayland-protocols-1.40.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2025 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit meson
+
+DESCRIPTION="Wayland protocol files"
+HOMEPAGE="https://wayland.freedesktop.org/"
+
+if [[ ${PV} = 9999* ]]; then
+ EGIT_REPO_URI="https://gitlab.freedesktop.org/wayland/${PN}.git/"
+ inherit git-r3
+else
+ SRC_URI="https://gitlab.freedesktop.org/wayland/${PN}/-/releases/${PV}/downloads/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="MIT"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ test? ( dev-libs/wayland )
+"
+BDEPEND="
+ >=dev-util/wayland-scanner-1.23.0
+ virtual/pkgconfig
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use test tests)
+ )
+ meson_src_configure
+}