summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2022-03-26 09:46:57 -0700
committerMatt Turner <mattst88@gentoo.org>2022-03-26 11:01:47 -0700
commit0a0ec569ef4991f5039ff59b1aa7d0b34d432d1f (patch)
tree8625af560fbaae60a214145f47fe1e27536b2616 /dev-libs
parentdev-python/trio: drop 0.20.0 (diff)
downloadgentoo-0a0ec569ef4991f5039ff59b1aa7d0b34d432d1f.tar.gz
gentoo-0a0ec569ef4991f5039ff59b1aa7d0b34d432d1f.tar.bz2
gentoo-0a0ec569ef4991f5039ff59b1aa7d0b34d432d1f.zip
dev-libs/folks: Version bump to 0.15.5
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/folks/Manifest1
-rw-r--r--dev-libs/folks/folks-0.15.5.ebuild96
2 files changed, 97 insertions, 0 deletions
diff --git a/dev-libs/folks/Manifest b/dev-libs/folks/Manifest
index ab921df7700c..19c0c8989688 100644
--- a/dev-libs/folks/Manifest
+++ b/dev-libs/folks/Manifest
@@ -1 +1,2 @@
DIST folks-0.15.4.tar.xz 493004 BLAKE2B 0e067a39b4e89e8fa41b20f37c774e56fcb1e0c8de23798ced647177b0d9329509ae3c03ff85a00464887deb4ce275c96b2fcf50aa2dd44af02e20b6ee45fe65 SHA512 4dbd0bb82d56a8cb179ab8148ce531817ccd55bd40f8b562eb0d77555b264e5190669b356ff009c81a963fdcacaabc02fe871bf0c3c668a648f2c820da76f25c
+DIST folks-0.15.5.tar.xz 492976 BLAKE2B bb831a637dec44ba0e9bb815c2559e3b7f484734fc297293c392bb2c72dea77c5e8aec3e7c76a096288f84f463041fb0b52a3cb50a83c5d84bed818c6af72a27 SHA512 696d158234cc5b4c504491c6e01dc45ed53c4ac02e3e62e637d229207dde396a82a850d143d8615dc838d99c756edfce145405ea3972c556951d6408fb8487ea
diff --git a/dev-libs/folks/folks-0.15.5.ebuild b/dev-libs/folks/folks-0.15.5.ebuild
new file mode 100644
index 000000000000..9ee2c090d991
--- /dev/null
+++ b/dev-libs/folks/folks-0.15.5.ebuild
@@ -0,0 +1,96 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+VALA_MIN_API_VERSION="0.48"
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit gnome.org gnome2-utils meson python-any-r1 vala xdg
+
+DESCRIPTION="Library for aggregating people from multiple sources"
+HOMEPAGE="https://wiki.gnome.org/Projects/Folks https://gitlab.gnome.org/GNOME/folks"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/26" # subslot = libfolks soname version
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~x86-linux"
+
+IUSE="bluetooth eds +telepathy test utils"
+REQUIRED_USE="bluetooth? ( eds )"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ >=dev-libs/glib-2.58:2
+ >=dev-libs/libgee-0.10:0.8[introspection]
+ >=dev-libs/gobject-introspection-1.54:=
+ telepathy? (
+ >=net-libs/telepathy-glib-0.19.9
+ dev-libs/dbus-glib
+ )
+ eds? ( >=gnome-extra/evolution-data-server-3.38:= )
+ dev-libs/libxml2:2
+ utils? ( sys-libs/readline:0= )
+"
+# telepathy-mission-control needed at runtime; it is used by the telepathy
+# backend via telepathy-glib's AccountManager binding.
+RDEPEND="${DEPEND}
+ bluetooth? ( >=net-wireless/bluez-5[obex] )
+ telepathy? ( net-im/telepathy-mission-control )
+"
+BDEPEND="
+ ${PYTHON_DEPS}
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+ $(vala_depend)
+ telepathy? ( net-libs/telepathy-glib[vala] )
+ eds? ( gnome-extra/evolution-data-server[vala] )
+ test? (
+ sys-apps/dbus
+ bluetooth? (
+ $(python_gen_any_dep '
+ dev-python/python-dbusmock[${PYTHON_USEDEP}]
+ ')
+ )
+ )
+"
+
+python_check_deps() {
+ if use test && use bluetooth; then
+ python_has_version "dev-python/python-dbusmock[${PYTHON_USEDEP}]"
+ fi
+}
+
+src_prepare() {
+ default
+ vala_setup
+ xdg_environment_reset
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use bluetooth bluez_backend)
+ $(meson_use eds eds_backend)
+ $(meson_use eds ofono_backend)
+ $(meson_use telepathy telepathy_backend)
+ -Dzeitgeist=false # last rited package
+ -Dimport_tool=true
+ $(meson_use utils inspect_tool)
+ $(meson_use test tests)
+ -Dinstalled_tests=false
+ -Ddocs=false # Needs find_program sedding to specific version; only dev docs, don't bother
+ )
+ meson_src_configure
+}
+
+src_test() {
+ dbus-run-session meson test -C "${BUILD_DIR}" -t 5
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_schemas_update
+}