summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMario Haustein <mario.haustein@hrz.tu-chemnitz.de>2023-04-25 21:26:10 +0200
committerSam James <sam@gentoo.org>2023-04-25 22:26:50 +0100
commit4a0585ceaa138e2c21cb08c68cfc2d147cd0db57 (patch)
tree4ab51a127951f1dc19beecc08e49c0dde586c902 /dev-libs
parentdev-libs/keystone: sync KEYWORDS to live template (diff)
downloadgentoo-4a0585ceaa138e2c21cb08c68cfc2d147cd0db57.tar.gz
gentoo-4a0585ceaa138e2c21cb08c68cfc2d147cd0db57.tar.bz2
gentoo-4a0585ceaa138e2c21cb08c68cfc2d147cd0db57.zip
dev-libs/keystone: use DISTUTILS_USE_PEP517
Signed-off-by: Mario Haustein <mario.haustein@hrz.tu-chemnitz.de> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/keystone/keystone-9999.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-libs/keystone/keystone-9999.ebuild b/dev-libs/keystone/keystone-9999.ebuild
index 0bb4e02daf89..0187a48fc4cd 100644
--- a/dev-libs/keystone/keystone-9999.ebuild
+++ b/dev-libs/keystone/keystone-9999.ebuild
@@ -4,7 +4,9 @@
EAPI=8
LLVM_MAX_SLOT=14
+DISTUTILS_EXT=1
DISTUTILS_OPTIONAL=1
+DISTUTILS_USE_PEP517=setuptools
PYTHON_COMPAT=( python3_{9..11} )
inherit cmake distutils-r1 llvm
@@ -29,14 +31,20 @@ ALL_LLVM_TARGETS=( AArch64 ARM Hexagon Mips PowerPC Sparc SystemZ X86 )
ALL_LLVM_TARGETS=( "${ALL_LLVM_TARGETS[@]/#/llvm_targets_}" )
LLVM_TARGET_USEDEPS=${ALL_LLVM_TARGETS[@]/%/?}
-IUSE="python ${ALL_LLVM_TARGETS[*]}"
+IUSE="debug python ${ALL_LLVM_TARGETS[*]}"
RDEPEND="
<sys-devel/llvm-$((${LLVM_MAX_SLOT} + 1)):=[${LLVM_TARGET_USEDEPS// /,}]
python? ( ${PYTHON_DEPS} )
"
DEPEND="${RDEPEND}"
-BDEPEND="${PYTHON_DEPS}"
+BDEPEND="
+ python?
+ (
+ ${DISTUTILS_DEPS}
+ ${PYTHON_DEPS}
+ )
+"
RESTRICT=test # only regression tests