summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-07-13 00:07:15 +0100
committerSam James <sam@gentoo.org>2023-07-13 00:07:15 +0100
commite05b37859baea238fd59b9a686b5891b76346686 (patch)
tree20f8bae9b5716737c181a740aa23fd6e23f036e7 /dev-libs
parentapp-dicts/wordnet: Stabilize 3.1-r1 amd64, #910257 (diff)
downloadgentoo-e05b37859baea238fd59b9a686b5891b76346686.tar.gz
gentoo-e05b37859baea238fd59b9a686b5891b76346686.tar.bz2
gentoo-e05b37859baea238fd59b9a686b5891b76346686.zip
dev-libs/botan: handle -fsanitize={address,undefined}
See https://github.com/randombit/botan/issues/3623#issuecomment-1632453228. We need to handle -fsanitize=address and -fsanitize=undefined and pass them through with the special build system options rather than passing them in raw. Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/botan/botan-3.1.0.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-libs/botan/botan-3.1.0.ebuild b/dev-libs/botan/botan-3.1.0.ebuild
index 556004d6c660..6cbda3afca02 100644
--- a/dev-libs/botan/botan-3.1.0.ebuild
+++ b/dev-libs/botan/botan-3.1.0.ebuild
@@ -5,7 +5,7 @@ EAPI=8
PYTHON_COMPAT=( python3_{10..12} )
VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/botan.asc
-inherit edo multiprocessing python-r1 toolchain-funcs verify-sig
+inherit edo flag-o-matic multiprocessing python-r1 toolchain-funcs verify-sig
MY_P="Botan-${PV}"
DESCRIPTION="C++ crypto library"
@@ -62,6 +62,7 @@ python_check_deps() {
}
src_configure() {
+ tc-export AR CC CXX
python_setup
local disable_modules=(
@@ -167,7 +168,17 @@ src_configure() {
)
fi
- tc-export AR CC CXX
+ local sanitizers=()
+ if is-flagq -fsanitize=address ; then
+ sanitizers+=( address )
+ fi
+ if is-flagq -fsanitize=undefined ; then
+ sanitizers+=( undefined )
+ fi
+ filter-flags '-fsanitize=*'
+ myargs+=(
+ --enable-sanitizers=$(IFS=","; echo "${sanitizers[*]}")
+ )
edo ${EPYTHON} configure.py --verbose "${myargs[@]}"
}