summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMaciej Barć <xgqt@gentoo.org>2024-06-16 13:12:28 +0200
committerMaciej Barć <xgqt@gentoo.org>2024-06-16 13:37:06 +0200
commite395547d7eb8679c22de54407de53671a4fa3ce5 (patch)
tree4ac29eebefbf3b74386f093fbf3c95e9cf26d122 /dev-libs
parentdev-libs/ayatana-ido: drop 0.9.2 (diff)
downloadgentoo-e395547d7eb8679c22de54407de53671a4fa3ce5.tar.gz
gentoo-e395547d7eb8679c22de54407de53671a4fa3ce5.tar.bz2
gentoo-e395547d7eb8679c22de54407de53671a4fa3ce5.zip
dev-libs/editline: bump EAPI - 7 -> 8; misc tweaks
Signed-off-by: Maciej Barć <xgqt@gentoo.org>
Diffstat (limited to 'dev-libs')
-rw-r--r--dev-libs/editline/editline-1.17.1-r1.ebuild (renamed from dev-libs/editline/editline-1.17.1.ebuild)26
1 files changed, 18 insertions, 8 deletions
diff --git a/dev-libs/editline/editline-1.17.1.ebuild b/dev-libs/editline/editline-1.17.1-r1.ebuild
index 0bba672748cf..72f6f005b20b 100644
--- a/dev-libs/editline/editline-1.17.1.ebuild
+++ b/dev-libs/editline/editline-1.17.1-r1.ebuild
@@ -1,17 +1,28 @@
# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
DESCRIPTION="line editing library for UNIX call compatible with the FSF readline"
-HOMEPAGE="https://troglobit.com/projects/editline/"
-SRC_URI="https://github.com/troglobit/editline/releases/download/${PV}/${P}.tar.xz"
+HOMEPAGE="https://troglobit.com/projects/editline/
+ https://github.com/troglobit/editline/"
+
+if [[ "${PV}" == *9999* ]] ; then
+ inherit git-r3
+
+ EGIT_REPO_URI="https://github.com/troglobit/${PN}.git"
+else
+ SRC_URI="https://github.com/troglobit/${PN}/releases/download/${PV}/${P}.tar.xz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
+SLOT="0/1.0.2"
-PATCHES=("${FILESDIR}"/${PN}-1.16.0-rename-man.patch)
+PATCHES=(
+ "${FILESDIR}/${PN}-1.16.0-rename-man.patch"
+)
src_prepare() {
default
@@ -28,6 +39,5 @@ src_configure() {
src_install() {
default
- # package installs .pc file
- find "${D}" -name '*.la' -delete || die
+ find "${D}" -type f -name "*.la" -delete || die
}