summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2020-11-29 01:55:11 +0100
committerConrad Kostecki <conikost@gentoo.org>2020-11-29 02:32:23 +0100
commitca240a16a012b7d4c547024841f1f48211e96f1f (patch)
tree92dd6465cfa980bb9482d09ab37214494741893d /dev-lua/luacheck
parentdev-lua/lua-argparse: migrate to lua eclass (diff)
downloadgentoo-ca240a16a012b7d4c547024841f1f48211e96f1f.tar.gz
gentoo-ca240a16a012b7d4c547024841f1f48211e96f1f.tar.bz2
gentoo-ca240a16a012b7d4c547024841f1f48211e96f1f.zip
dev-lua/luacheck: migrate to lua eclass
Bug: https://bugs.gentoo.org/723156 Bug: https://bugs.gentoo.org/729794 Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua/luacheck')
-rw-r--r--dev-lua/luacheck/files/luacheck-0.23.0-disable-measuring-performance-test.patch13
-rw-r--r--dev-lua/luacheck/luacheck-0.23.0-r100.ebuild65
2 files changed, 78 insertions, 0 deletions
diff --git a/dev-lua/luacheck/files/luacheck-0.23.0-disable-measuring-performance-test.patch b/dev-lua/luacheck/files/luacheck-0.23.0-disable-measuring-performance-test.patch
new file mode 100644
index 000000000000..04d40ec958b6
--- /dev/null
+++ b/dev-lua/luacheck/files/luacheck-0.23.0-disable-measuring-performance-test.patch
@@ -0,0 +1,13 @@
+--- a/spec/cli_spec.lua
++++ b/spec/cli_spec.lua
+@@ -68,10 +68,6 @@
+ assert.equal(0, get_exitcode "spec/samples/good_code.lua --no-config")
+ end)
+
+- it("allows measuring performance", function()
+- assert.equal(0, get_exitcode "spec/samples/good_code.lua --no-config --profile")
+- end)
+-
+ it("removes ./ in the beginnings of file names", function()
+ assert.equal([[
+ Checking spec/samples/good_code.lua OK
diff --git a/dev-lua/luacheck/luacheck-0.23.0-r100.ebuild b/dev-lua/luacheck/luacheck-0.23.0-r100.ebuild
new file mode 100644
index 000000000000..995faeb6e699
--- /dev/null
+++ b/dev-lua/luacheck/luacheck-0.23.0-r100.ebuild
@@ -0,0 +1,65 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..3} luajit )
+
+inherit lua toolchain-funcs
+
+DESCRIPTION="A tool for linting and static analysis of Lua code"
+HOMEPAGE="https://github.com/mpeterv/luacheck"
+SRC_URI="https://github.com/mpeterv/luacheck/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~x86"
+IUSE="doc test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-lua/lua-argparse-0.6.0-r100[${LUA_USEDEP}]
+ >=dev-lua/lua-utf8-0.1.3-r100[${LUA_USEDEP}]
+ >=dev-lua/luafilesystem-1.8.0-r100[${LUA_USEDEP}]
+"
+
+DEPEND="${RDEPEND}"
+
+BDEPEND="
+ virtual/pkgconfig
+ doc? ( dev-python/sphinx )
+ test? (
+ >=dev-lua/busted-2.0.0-r100[${LUA_USEDEP}]
+ ${RDEPEND}
+ )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.23.0-disable-measuring-performance-test.patch" )
+
+src_compile() {
+ if use doc; then
+ sphinx-build docsrc html || die
+ fi
+}
+
+lua_src_test() {
+ busted --lua=${ELUA} || die
+}
+
+src_test() {
+ lua_foreach_impl lua_src_test
+}
+
+lua_src_install() {
+ insinto "$(lua_get_lmod_dir)"
+ doins -r src/luacheck
+}
+
+src_install() {
+ lua_foreach_impl lua_src_install
+
+ newbin bin/luacheck.lua luacheck
+
+ use doc && local -a HTML_DOCS=( "html/." )
+ einstalldocs
+}