summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorConrad Kostecki <conikost@gentoo.org>2022-02-09 21:37:24 +0100
committerConrad Kostecki <conikost@gentoo.org>2022-02-09 23:55:53 +0100
commitf167ab87d356dda2d0dc5e0fa8a81cde497e742f (patch)
treedae2ee50e722d6f38a9952599e05378d12c3a005 /dev-lua
parentdev-lua/mediator_lua: update EAPI 7 -> 8 (diff)
downloadgentoo-f167ab87d356dda2d0dc5e0fa8a81cde497e742f.tar.gz
gentoo-f167ab87d356dda2d0dc5e0fa8a81cde497e742f.tar.bz2
gentoo-f167ab87d356dda2d0dc5e0fa8a81cde497e742f.zip
dev-lua/mediator_lua: drop 1.1.2_p0-r101
Signed-off-by: Conrad Kostecki <conikost@gentoo.org>
Diffstat (limited to 'dev-lua')
-rw-r--r--dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r101.ebuild50
1 files changed, 0 insertions, 50 deletions
diff --git a/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r101.ebuild b/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r101.ebuild
deleted file mode 100644
index 06672068c3b9..000000000000
--- a/dev-lua/mediator_lua/mediator_lua-1.1.2_p0-r101.ebuild
+++ /dev/null
@@ -1,50 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-LUA_COMPAT=( lua5-{1..4} luajit )
-MY_PV="${PV/_p/-}"
-
-inherit lua toolchain-funcs
-
-DESCRIPTION="Mediator pattern implementation for pub-sub management"
-HOMEPAGE="http://olivinelabs.com/mediator_lua/"
-SRC_URI="https://github.com/Olivine-Labs/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.tar.gz"
-S="${WORKDIR}/${PN}-${MY_PV}"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~riscv ~sparc x86"
-IUSE="test"
-REQUIRED_USE="${LUA_REQUIRED_USE}"
-RESTRICT="!test? ( test )"
-
-RDEPEND="${LUA_DEPS}"
-BDEPEND="
- virtual/pkgconfig
- test? (
- dev-lua/busted[${LUA_USEDEP}]
- dev-lua/lua_cliargs[${LUA_USEDEP}]
- ${RDEPEND}
- )
-"
-
-lua_src_test() {
- busted --lua=${ELUA} || die
-}
-
-src_test() {
- lua_foreach_impl lua_src_test
-}
-
-lua_src_install() {
- insinto $(lua_get_lmod_dir)
- doins src/mediator.lua
-}
-
-src_install() {
- lua_foreach_impl lua_src_install
-
- einstalldocs
-}