summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2024-06-05 20:22:24 +0200
committerAlfredo Tupone <tupone@gentoo.org>2024-06-05 20:22:45 +0200
commit67597398df2977f42379813d4292dcf6fc7c3c60 (patch)
treebc12456b35ddf24747e4e97acf295d1176612a62 /dev-ml/ocaml-ctypes
parentmedia-video/subtitlecomposer: Fix build w/ ICU-75 (diff)
downloadgentoo-67597398df2977f42379813d4292dcf6fc7c3c60.tar.gz
gentoo-67597398df2977f42379813d4292dcf6fc7c3c60.tar.bz2
gentoo-67597398df2977f42379813d4292dcf6fc7c3c60.zip
dev-ml/ocaml-ctypes: fix make
Closes: https://bugs.gentoo.org/911531 Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-ctypes')
-rw-r--r--dev-ml/ocaml-ctypes/files/ocaml-ctypes-0.20.1-shuffle.patch29
-rw-r--r--dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild7
2 files changed, 34 insertions, 2 deletions
diff --git a/dev-ml/ocaml-ctypes/files/ocaml-ctypes-0.20.1-shuffle.patch b/dev-ml/ocaml-ctypes/files/ocaml-ctypes-0.20.1-shuffle.patch
new file mode 100644
index 000000000000..1b56526f2abf
--- /dev/null
+++ b/dev-ml/ocaml-ctypes/files/ocaml-ctypes-0.20.1-shuffle.patch
@@ -0,0 +1,29 @@
+--- a/Makefile 2023-01-24 08:35:02.515456277 +0100
++++ b/Makefile 2023-01-24 08:35:45.459755298 +0100
+@@ -81,7 +81,7 @@
+ cstubs.public = cstubs_structs cstubs cstubs_inverted
+ cstubs.dir = src/cstubs
+ cstubs.subproject_deps = ctypes
+-cstubs.deps = str integers
++cstubs.deps = bigarray-compat str integers
+ cstubs.install = yes
+ cstubs.install_native_objects = yes
+ cstubs.extra_hs = $(package_integers_path)/ocaml_integers.h
+@@ -93,7 +93,7 @@
+ ctypes-foreign.public = dl libffi_abi foreign
+ ctypes-foreign.dir = src/ctypes-foreign
+ ctypes-foreign.subproject_deps = ctypes
+-ctypes-foreign.deps = integers
++ctypes-foreign.deps = bigarray-compat integers
+ ctypes-foreign.install = yes
+ ctypes-foreign.install_native_objects = yes
+ ctypes-foreign.extra_cs = dl_stubs.c
+@@ -111,7 +111,7 @@
+ ctypes-top.public = ctypes_printers
+ ctypes-top.dir = src/ctypes-top
+ ctypes-top.install = yes
+-ctypes-top.deps = compiler-libs integers
++ctypes-top.deps = bigarray-compat compiler-libs integers
+ ctypes-top.subproject_deps = ctypes
+ ctypes-top.install_native_objects = yes
+
diff --git a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild
index f321f7db9334..e088849da77f 100644
--- a/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild
+++ b/dev-ml/ocaml-ctypes/ocaml-ctypes-0.20.1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2023 Gentoo Authors
+# Copyright 1999-2024 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
@@ -25,7 +25,10 @@ DEPEND="${RDEPEND}
test? ( dev-ml/ounit2 dev-ml/lwt )"
REQUIRED_USE="ocamlopt"
-PATCHES=( "${FILESDIR}"/${PN}-0.20.0-shuffle.patch )
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.20.0-shuffle.patch
+ "${FILESDIR}"/${P}-shuffle.patch
+)
src_prepare() {
sed -e 's/oUnit/ounit2/g' -i Makefile.tests || die