summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2020-10-19 21:37:42 +0000
committerSam James <sam@gentoo.org>2020-10-20 01:37:16 +0000
commit855fd9dbcfd594da29eb7bcf9e27bd6ccc32df94 (patch)
treefd206dd9f8986e468936d4682111c25763d97201 /dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild
parentdev-ml/ocurl: cleanup old (diff)
downloadgentoo-855fd9dbcfd594da29eb7bcf9e27bd6ccc32df94.tar.gz
gentoo-855fd9dbcfd594da29eb7bcf9e27bd6ccc32df94.tar.bz2
gentoo-855fd9dbcfd594da29eb7bcf9e27bd6ccc32df94.zip
dev-ml/ocaml-ssl: bump to 0.5.9
Package-Manager: Portage-3.0.8, Repoman-3.0.1 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild')
-rw-r--r--dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild
new file mode 100644
index 000000000000..0bb8af882f5a
--- /dev/null
+++ b/dev-ml/ocaml-ssl/ocaml-ssl-0.5.9.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DUNE_PKG_NAME="ssl"
+inherit dune
+
+DESCRIPTION="OCaml bindings for OpenSSL"
+SRC_URI="https://github.com/savonet/ocaml-ssl/archive/${PV}.tar.gz -> ${P}.tar.gz"
+HOMEPAGE="https://github.com/savonet/ocaml-ssl"
+
+IUSE="doc +ocamlopt"
+
+DEPEND="dev-libs/openssl:0=
+ >=dev-lang/ocaml-3.10:=[ocamlopt?]"
+RDEPEND="${DEPEND}"
+
+SLOT="0/${PV}"
+LICENSE="LGPL-2.1"
+KEYWORDS="~amd64 ~arm ~x86"
+
+src_install() {
+ dune_src_install
+
+ dodoc CHANGES README.md
+
+ if use doc; then
+ docinto html
+ dodoc -r doc/html/*
+ fi
+}