summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlfredo Tupone <tupone@gentoo.org>2022-12-21 12:34:34 +0100
committerAlfredo Tupone <tupone@gentoo.org>2022-12-21 12:35:01 +0100
commit3f1ee29dd49b4e7933e1d53eda6339a3345cbd03 (patch)
tree45240c6145a523e36bdac726d17722ea38302398 /dev-ml/odoc-parser
parentx11-misc/i3lock: add missing dependency on x11-libs/xcb-util-image (diff)
downloadgentoo-3f1ee29dd49b4e7933e1d53eda6339a3345cbd03.tar.gz
gentoo-3f1ee29dd49b4e7933e1d53eda6339a3345cbd03.tar.bz2
gentoo-3f1ee29dd49b4e7933e1d53eda6339a3345cbd03.zip
dev-ml/odoc-parser: new package, add 2.0.0
Signed-off-by: Alfredo Tupone <tupone@gentoo.org>
Diffstat (limited to 'dev-ml/odoc-parser')
-rw-r--r--dev-ml/odoc-parser/Manifest1
-rw-r--r--dev-ml/odoc-parser/metadata.xml17
-rw-r--r--dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild26
3 files changed, 44 insertions, 0 deletions
diff --git a/dev-ml/odoc-parser/Manifest b/dev-ml/odoc-parser/Manifest
new file mode 100644
index 000000000000..05f96d89e115
--- /dev/null
+++ b/dev-ml/odoc-parser/Manifest
@@ -0,0 +1 @@
+DIST odoc-parser-2.0.0.tbz 34826 BLAKE2B 0d167fa7d768dfac3b45740707b0a84d300999ef4334ade70286675d906cd7d8c70fcd27e563fb0ab4450f6a0ff8097884af267b376b51e7a91ccfbecb8ac06c SHA512 d2bffa3e9f30471045682e390dcee7a2c1caf3831bca4bd57c16939e782c2e23434e6f1c9887580a1804800b3629ef4c4311a9d418fca5a939f324650d54006e
diff --git a/dev-ml/odoc-parser/metadata.xml b/dev-ml/odoc-parser/metadata.xml
new file mode 100644
index 000000000000..c62c1cd9bcf5
--- /dev/null
+++ b/dev-ml/odoc-parser/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>ml@gentoo.org</email>
+ <name>ML</name>
+ </maintainer>
+ <longdescription>
+ Odoc_parser is a library for parsing the contents of OCaml
+ documentation comments, formatted using 'odoc' syntax, an extension
+ of the language understood by ocamldoc.
+ </longdescription>
+ <upstream>
+ <bugs-to>https://github.com/ocaml-doc/odoc-parser/issues/</bugs-to>
+ <remote-id type="github">ocaml-doc/odoc-parser</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild b/dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild
new file mode 100644
index 000000000000..70381f8c32d2
--- /dev/null
+++ b/dev-ml/odoc-parser/odoc-parser-2.0.0.ebuild
@@ -0,0 +1,26 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit dune
+
+DESCRIPTION="Parser for ocaml documentation comments"
+HOMEPAGE="https://github.com/ocaml-doc/odoc-parser"
+SRC_URI="https://github.com/ocaml-doc/odoc-parser/releases/download/${PV}/${P}.tbz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="+ocamlopt test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-ml/astring:=
+ dev-ml/result:=
+ dev-ml/camlp-streams:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="test? (
+ dev-ml/ppx_expect
+)"