summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEli Schwartz <eschwartz93@gmail.com>2024-02-29 18:39:22 -0500
committerSam James <sam@gentoo.org>2024-02-29 23:57:40 +0000
commita8c2b35f50a01d401be9c29abe6d720804ebbe44 (patch)
tree3cabaa751ac73866e04d09ba0fabef406d664a16 /dev-ml/zarith
parentapp-office/libalkimia: remove gmp USE flag, force it instead of mpir (diff)
downloadgentoo-a8c2b35f50a01d401be9c29abe6d720804ebbe44.tar.gz
gentoo-a8c2b35f50a01d401be9c29abe6d720804ebbe44.tar.bz2
gentoo-a8c2b35f50a01d401be9c29abe6d720804ebbe44.zip
dev-ml/zarith: remove support for mpir USE flag
mpir is an ancient fork of gmp from 2017. It claims to be focused on speed. It doesn't build with modern compilers due to Modern C issues, and it fails to build with LTO as well. Unlike gmp, this will never be fixed. Bug: https://bugs.gentoo.org/812950 Signed-off-by: Eli Schwartz <eschwartz93@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-ml/zarith')
-rw-r--r--dev-ml/zarith/zarith-1.13.ebuild8
1 files changed, 3 insertions, 5 deletions
diff --git a/dev-ml/zarith/zarith-1.13.ebuild b/dev-ml/zarith/zarith-1.13.ebuild
index ffe8f2bf2cdc..cc89cb150c39 100644
--- a/dev-ml/zarith/zarith-1.13.ebuild
+++ b/dev-ml/zarith/zarith-1.13.ebuild
@@ -12,13 +12,12 @@ SRC_URI="https://github.com/ocaml/Zarith/archive/release-${PV}.tar.gz -> ${P}.ta
LICENSE="LGPL-2.1-with-linking-exception"
SLOT="0/${PV}"
KEYWORDS="~amd64 ~arm ~arm64 ~ppc x86"
-IUSE="doc mpir +ocamlopt"
+IUSE="doc +ocamlopt"
RESTRICT="!ocamlopt? ( test )"
RDEPEND="
>=dev-lang/ocaml-4.05:=[ocamlopt=]
- !mpir? ( dev-libs/gmp:0= )
- mpir? ( sci-libs/mpir:= )
+ dev-libs/gmp:0=
"
DEPEND="${RDEPEND} dev-lang/perl"
@@ -29,8 +28,7 @@ S="${WORKDIR}/Zarith-release-${PV}"
src_configure() {
tc-export CC AR
./configure \
- -ocamllibdir /usr/$(get_libdir)/ocaml \
- $(usex mpir "-mpir" "-gmp") || die
+ -ocamllibdir /usr/$(get_libdir)/ocaml -gmp || die
sed -i \
-e 's|$(INSTALLDIR)|$(DESTDIR)$(INSTALLDIR)|g' \
project.mak || die