summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-07-03 11:35:39 +1200
committerKent Fredric <kentnl@gentoo.org>2020-07-03 11:57:28 +1200
commitaff523bb17402af832c78b5e5c824f9b08beb33f (patch)
tree5fc7023ef8dd4dc17d1014a1a5b73866db470fc4 /dev-perl/Audio-FLAC-Header
parentdev-perl/Audio-DSP: -r bump for EAPI7/CFLAGS love (diff)
downloadgentoo-aff523bb17402af832c78b5e5c824f9b08beb33f.tar.gz
gentoo-aff523bb17402af832c78b5e5c824f9b08beb33f.tar.bz2
gentoo-aff523bb17402af832c78b5e5c824f9b08beb33f.zip
dev-perl/Audio-FLAC-Header: -r bump for CFLAGS love
- Ensure CFLAGS are passed to make/compiler Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/Audio-FLAC-Header')
-rw-r--r--dev-perl/Audio-FLAC-Header/Audio-FLAC-Header-2.400.0-r3.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/dev-perl/Audio-FLAC-Header/Audio-FLAC-Header-2.400.0-r3.ebuild b/dev-perl/Audio-FLAC-Header/Audio-FLAC-Header-2.400.0-r3.ebuild
new file mode 100644
index 000000000000..0aebdff020a1
--- /dev/null
+++ b/dev-perl/Audio-FLAC-Header/Audio-FLAC-Header-2.400.0-r3.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DIST_AUTHOR=DANIEL
+DIST_VERSION=2.4
+inherit perl-module
+
+DESCRIPTION="Access to FLAC audio metadata"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos"
+
+RDEPEND="media-libs/flac"
+DEPEND="${RDEPEND}"
+BDEPEND="${RDEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-2.4-no-dot-inc.patch"
+)
+PERL_RM_FILES=(
+ "t/pod.t"
+ "t/pod-coverage.t"
+)
+src_compile() {
+ mymake=(
+ "OPTIMIZE=${CFLAGS}"
+ )
+ perl-module_src_compile
+}