summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-05 09:38:51 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-05 09:39:25 +1300
commit922ea78eb95a890c4ca6bcf9f759c06e02dc696e (patch)
tree2417181636fc13c6a4fe65b1d32914f6a30fc149 /dev-perl/BSON
parentdev-perl/Moo: Bump to version 2.2.5 (diff)
downloadgentoo-922ea78eb95a890c4ca6bcf9f759c06e02dc696e.tar.gz
gentoo-922ea78eb95a890c4ca6bcf9f759c06e02dc696e.tar.bz2
gentoo-922ea78eb95a890c4ca6bcf9f759c06e02dc696e.zip
dev-perl/BSON: Added w/ version 1.2.2
Required for newer dev-perl/MongoDB Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-perl/BSON')
-rw-r--r--dev-perl/BSON/BSON-1.2.2.ebuild43
-rw-r--r--dev-perl/BSON/Manifest1
-rw-r--r--dev-perl/BSON/metadata.xml33
3 files changed, 77 insertions, 0 deletions
diff --git a/dev-perl/BSON/BSON-1.2.2.ebuild b/dev-perl/BSON/BSON-1.2.2.ebuild
new file mode 100644
index 000000000000..c569c2de71a2
--- /dev/null
+++ b/dev-perl/BSON/BSON-1.2.2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MONGODB
+DIST_VERSION=v1.2.2
+inherit perl-module
+
+DESCRIPTION="BSON serialization and deserialization"
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Digest-MD5
+ virtual/perl-Exporter
+ virtual/perl-Math-BigInt
+ >=dev-perl/Moo-2.2.4
+ virtual/perl-Scalar-List-Utils
+ dev-perl/Tie-IxHash
+ virtual/perl-Time-HiRes
+ virtual/perl-Time-Local
+ >=dev-perl/boolean-0.450.0
+ dev-perl/namespace-clean
+ virtual/perl-threads-shared
+ virtual/perl-version
+"
+DEPEND="${RDEPEND}
+ >=virtual/perl-ExtUtils-MakeMaker-6.170.0
+ test? (
+ >=virtual/perl-CPAN-Meta-2.120.900
+ virtual/perl-Data-Dumper
+ virtual/perl-File-Spec
+ dev-perl/JSON-MaybeXS
+ >=dev-perl/Path-Tiny-0.54.0
+ dev-perl/Test-Deep
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"
diff --git a/dev-perl/BSON/Manifest b/dev-perl/BSON/Manifest
new file mode 100644
index 000000000000..b12ec59a746b
--- /dev/null
+++ b/dev-perl/BSON/Manifest
@@ -0,0 +1 @@
+DIST BSON-v1.2.2.tar.gz 99492 SHA256 4a2225fbfb649504e2f9821038e067b94d33b4df4ab3ecf75b63a5def05af2f8 SHA512 e557b527ea77a443d9524779514495321af0eeb3f72f2e8eb7d53514408a13eef797143add94c93b4b563136ce62a5a95ee879c82ded7e32116650e016c1f1c3 WHIRLPOOL 94dd0356539d79cfc44187f0f451f9ef6bba71f772a413754f55c8257b55574f3f3f72b642619deed168ba71956342e491c3b688d1daaa4cfd16c5b87afc7779
diff --git a/dev-perl/BSON/metadata.xml b/dev-perl/BSON/metadata.xml
new file mode 100644
index 000000000000..d535b9a0609c
--- /dev/null
+++ b/dev-perl/BSON/metadata.xml
@@ -0,0 +1,33 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>perl@gentoo.org</email>
+ <name>Gentoo Perl Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="cpan">BSON</remote-id>
+ <remote-id type="cpan-module">BSON</remote-id>
+ <remote-id type="cpan-module">BSON::Binary</remote-id>
+ <remote-id type="cpan-module">BSON::Bool</remote-id>
+ <remote-id type="cpan-module">BSON::Bytes</remote-id>
+ <remote-id type="cpan-module">BSON::Code</remote-id>
+ <remote-id type="cpan-module">BSON::DBRef</remote-id>
+ <remote-id type="cpan-module">BSON::Decimal128</remote-id>
+ <remote-id type="cpan-module">BSON::Doc</remote-id>
+ <remote-id type="cpan-module">BSON::Double</remote-id>
+ <remote-id type="cpan-module">BSON::Int32</remote-id>
+ <remote-id type="cpan-module">BSON::Int64</remote-id>
+ <remote-id type="cpan-module">BSON::MaxKey</remote-id>
+ <remote-id type="cpan-module">BSON::MinKey</remote-id>
+ <remote-id type="cpan-module">BSON::OID</remote-id>
+ <remote-id type="cpan-module">BSON::ObjectId</remote-id>
+ <remote-id type="cpan-module">BSON::PP</remote-id>
+ <remote-id type="cpan-module">BSON::Raw</remote-id>
+ <remote-id type="cpan-module">BSON::Regex</remote-id>
+ <remote-id type="cpan-module">BSON::String</remote-id>
+ <remote-id type="cpan-module">BSON::Time</remote-id>
+ <remote-id type="cpan-module">BSON::Timestamp</remote-id>
+ <remote-id type="cpan-module">BSON::Types</remote-id>
+ </upstream>
+</pkgmetadata>