summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-21 01:55:52 +0100
committerSam James <sam@gentoo.org>2023-06-21 02:13:30 +0100
commit76b67d579e25ee728737229ebed34cf881645369 (patch)
tree11e7cbe9a358525f91f9cfe90af9c2e08851a280 /dev-perl/List-SomeUtils/List-SomeUtils-0.590.0.ebuild
parentdev-perl/List-UtilsBy: add 0.120.0 (diff)
downloadgentoo-76b67d579e25ee728737229ebed34cf881645369.tar.gz
gentoo-76b67d579e25ee728737229ebed34cf881645369.tar.bz2
gentoo-76b67d579e25ee728737229ebed34cf881645369.zip
dev-perl/List-SomeUtils: add 0.590.0
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-perl/List-SomeUtils/List-SomeUtils-0.590.0.ebuild')
-rw-r--r--dev-perl/List-SomeUtils/List-SomeUtils-0.590.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-perl/List-SomeUtils/List-SomeUtils-0.590.0.ebuild b/dev-perl/List-SomeUtils/List-SomeUtils-0.590.0.ebuild
new file mode 100644
index 000000000000..88d1d6883de6
--- /dev/null
+++ b/dev-perl/List-SomeUtils/List-SomeUtils-0.590.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DIST_AUTHOR=DROLSKY
+DIST_VERSION=0.59
+inherit perl-module
+
+DESCRIPTION="Collection of List utilities missing from List::Util"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+
+RDEPEND="
+ virtual/perl-Carp
+ virtual/perl-Exporter
+ >=dev-perl/Module-Implementation-0.40.0
+ >=dev-perl/List-SomeUtils-XS-0.550.0
+"
+BDEPEND="
+ ${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ virtual/perl-Text-ParseWords
+ test? (
+ virtual/perl-File-Spec
+ dev-perl/Test-LeakTrace
+ >=virtual/perl-Test-Simple-0.960.0
+ )
+"