summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentfredric@gmail.com>2016-03-01 23:11:15 +1300
committerKent Fredric <kentfredric@gmail.com>2016-03-02 00:01:03 +1300
commit48762e2df3096662d88585fb36d0f2556a3784e8 (patch)
tree496831fdb85b763ccfd724556776d9b5ec64002f /dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.4.ebuild
parentsci-libs/libccd: README has been renamed to README.md in git; bug #574906 by ... (diff)
downloadgentoo-48762e2df3096662d88585fb36d0f2556a3784e8.tar.gz
gentoo-48762e2df3096662d88585fb36d0f2556a3784e8.tar.bz2
gentoo-48762e2df3096662d88585fb36d0f2556a3784e8.zip
dev-perl/Net-LDAPapi: Bump to version 3.0.4
- EAPI6 Package-Manager: portage-2.2.27
Diffstat (limited to 'dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.4.ebuild')
-rw-r--r--dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.4.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.4.ebuild b/dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.4.ebuild
new file mode 100644
index 000000000000..cb0d000fad5d
--- /dev/null
+++ b/dev-perl/Net-LDAPapi/Net-LDAPapi-3.0.4.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+DIST_AUTHOR=MISHIKAL
+
+inherit eutils multilib perl-module
+
+DESCRIPTION="Perl5 Module Supporting LDAP API"
+HOMEPAGE="http://sourceforge.net/projects/net-ldapapi/
+ http://search.cpan.org/~mishikal/Net-LDAPapi/"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples"
+# LICENSE is given on the corresponding sourceforge project and matches the
+# default cpan/perl license
+
+RDEPEND="net-nds/openldap[sasl]
+ dev-libs/cyrus-sasl
+ dev-perl/Convert-ASN1"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker"
+
+# NOTE: tests are available but they hang
+# Tests also require hand-customised live LDAP server
+# and configured LDAP Search Base
+RESTRICT="test"
+
+PATCHES=("${FILESDIR}/${PV}-ldap_result-no_error.patch")
+
+src_configure() {
+ myconf="-sdk OpenLDAP -lib_path /usr/$(get_libdir) -include_path /usr/include"
+ perl-module_src_configure
+}
+
+src_install() {
+ mydoc="Credits Todo"
+ perl-module_src_install
+ if use examples ; then
+ docompress -x usr/share/doc/${PF}/examples
+ insinto /usr/share/doc/${PF}
+ doins -r examples
+ fi
+}