summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2020-04-16 01:07:40 +1200
committerKent Fredric <kentnl@gentoo.org>2020-04-16 01:08:02 +1200
commitd742f12a0435de00248aeee8b6cb17a8746b7769 (patch)
treeb370015d78816cec002e2d172f4d76bd91cd6d48 /dev-perl/OpenGL
parentdev-perl/Ogg-Vorbis-Header: Remove old 0.30.0-r2 (diff)
downloadgentoo-d742f12a0435de00248aeee8b6cb17a8746b7769.tar.gz
gentoo-d742f12a0435de00248aeee8b6cb17a8746b7769.tar.bz2
gentoo-d742f12a0435de00248aeee8b6cb17a8746b7769.zip
dev-perl/OpenGL: Remove old 0.670.400
Package-Manager: Portage-2.3.97, Repoman-2.3.22 Signed-off-by: Kent Fredric <kentnl@gentoo.org>
Diffstat (limited to 'dev-perl/OpenGL')
-rw-r--r--dev-perl/OpenGL/Manifest1
-rw-r--r--dev-perl/OpenGL/OpenGL-0.670.400.ebuild49
-rw-r--r--dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch50
3 files changed, 0 insertions, 100 deletions
diff --git a/dev-perl/OpenGL/Manifest b/dev-perl/OpenGL/Manifest
index 78ca8c853ea8..3c321839ebf2 100644
--- a/dev-perl/OpenGL/Manifest
+++ b/dev-perl/OpenGL/Manifest
@@ -1,2 +1 @@
-DIST OpenGL-0.6704.tar.gz 623036 BLAKE2B 1eb4821212b7ed04ad8c8d884d4441eb7de699ddd53f12c983ec912f535dbbe04b0529b42edfec3dd71f70f23bfe646c7c359116b81b1133df26aa05384c203b SHA512 3a2c9970802242ebae58256cd80dc81ac04a2af974105d3fbdf4dfcf1aa64a769b1ffcb5b0156eceb6bf7aed6eb6b2eb9332ec9f4724b0a1bc61d15f0de99d09
DIST OpenGL-0.70.tar.gz 783810 BLAKE2B 9112057cb0eed654827aaed84646c31d80833f6cce90a7a6066d648558c90ade0126b4f79033bef08adce1e3024c2eb4d1e6b10d4807bb422bce18ffcb1baba9 SHA512 7d418015b2553dd69805252b5957bc97013260617d5a358f692e29b8da884590421c81fbc71d4dd678c93a5c89047d6af8c32f15bf0bd0e4ce514c200e634af5
diff --git a/dev-perl/OpenGL/OpenGL-0.670.400.ebuild b/dev-perl/OpenGL/OpenGL-0.670.400.ebuild
deleted file mode 100644
index 31cacaff5d95..000000000000
--- a/dev-perl/OpenGL/OpenGL-0.670.400.ebuild
+++ /dev/null
@@ -1,49 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-DIST_AUTHOR=CHM
-DIST_VERSION=0.6704
-
-inherit perl-module eutils
-
-DESCRIPTION="Perl interface providing graphics display using OpenGL"
-
-SLOT="0"
-KEYWORDS="amd64 arm ppc ~ppc64 x86 ~amd64-linux ~x86-linux"
-IUSE="examples"
-
-RDEPEND="
- media-libs/freeglut:0=
- x11-libs/libICE:0=
- x11-libs/libXext:0=
- x11-libs/libXi:0=
- x11-libs/libXmu:0="
-DEPEND="${RDEPEND}"
-
-mydoc="Release_Notes"
-
-src_prepare() {
- eapply "${FILESDIR}"/${PN}-0.66-no-display.patch
- # This should be merely moved to t/ as it gets
- # installed to OS otherwise.
- # But it presently fails tests, and can't be made not to.
- # ( And will need virtualx when it can )
- # Something to do with OpenGL implementation ala eselect.
- perl_rm_files "test.pl";
- perl-module_src_prepare
-}
-
-src_compile() {
- sed -i -e 's/PERL_DL_NONLAZY=1//' Makefile || die
- perl-module_src_compile
-}
-src_install() {
- perl-module_src_install
- if use examples; then
- docompress -x /usr/share/doc/${PF}/examples
- insinto /usr/share/doc/${PF}/examples
- doins -r examples/*
- fi
-}
diff --git a/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch b/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
deleted file mode 100644
index 6bdc334ba0b1..000000000000
--- a/dev-perl/OpenGL/files/OpenGL-0.66-no-display.patch
+++ /dev/null
@@ -1,50 +0,0 @@
-Don't check current display for extensions, build all.
-
-diff -up OpenGL-0.62/Makefile.PL.dist OpenGL-0.62/Makefile.PL
---- OpenGL-0.62/Makefile.PL.dist 2009-12-11 01:10:00.000000000 +0100
-+++ OpenGL-0.62/Makefile.PL 2010-01-07 13:00:26.000000000 +0100
-@@ -579,9 +579,9 @@ my $build_config =
- {
- FILES =>
- "Config.pm ".
-- "utils/glversion.txt ".
-- "utils/glversion$Config{exe_ext} ".
-- "utils/glversion$Config{obj_ext}"
-+ "utils/glversion.txt "
-+ #"utils/glversion$Config{exe_ext} ".
-+ #"utils/glversion$Config{obj_ext}"
- }
- };
-
-@@ -790,6 +790,7 @@ sub get_extensions
- print "GLUT not found\n";
- }
-
-+=cut
- # Platform-specific makefiles for glversion
- my $make_ver;
- if ($IS_MINGW)
-@@ -848,7 +849,9 @@ sub get_extensions
- print "get_extensions: no extensions found in $glv_file\n" if $verbose;
- return '';
- }
--
-+=cut
-+ use Config;
-+ my $gldata = { };
-
- # Parse glext_procs.h file
- return '' if (!open(GLEXT,"glext_procs.h"));
-@@ -867,10 +870,12 @@ sub get_extensions
-
- # Create gl_exclude.h
- die "Unable to write to $exc_file\n" if (!open(GLEXC,">$exc_file"));
-+=cut
- print GLEXC "// OpenGL Extension Exclusions - may be modified before building.\n";
- print GLEXC "//\n";
- print GLEXC "// Generated for ".$gldata->{VENDOR}.", ".$gldata->{RENDERER}."\n";
- print GLEXC "// OpenGL v".$gldata->{VERSION}.", using ";
-+=cut
-
- # Fix GLUT flags based on results
- if ($gldata->{GLUT} > 0)