summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2017-05-30 14:18:08 +1200
committerKent Fredric <kentnl@gentoo.org>2017-05-30 14:18:08 +1200
commit9cb2f1c3ba0b44aca6e3e48fd840b2dec6121501 (patch)
tree2582f9d777f76703ea8fc7a019a4bcdd6d6f0b98 /dev-perl/Test-Deep
parentdev-perl/Specio: Bump to version 0.370.0 (diff)
downloadgentoo-9cb2f1c3ba0b44aca6e3e48fd840b2dec6121501.tar.gz
gentoo-9cb2f1c3ba0b44aca6e3e48fd840b2dec6121501.tar.bz2
gentoo-9cb2f1c3ba0b44aca6e3e48fd840b2dec6121501.zip
dev-perl/Test-Deep: Bump to version 1.127.0
Upstream: - Don't prematurely convert simple scalars to tests in any/all/none as this breaks leaf-wrapper application Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'dev-perl/Test-Deep')
-rw-r--r--dev-perl/Test-Deep/Manifest1
-rw-r--r--dev-perl/Test-Deep/Test-Deep-1.127.0.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-perl/Test-Deep/Manifest b/dev-perl/Test-Deep/Manifest
index 3400f3f6e543..00973c70fbbb 100644
--- a/dev-perl/Test-Deep/Manifest
+++ b/dev-perl/Test-Deep/Manifest
@@ -1 +1,2 @@
DIST Test-Deep-1.126.tar.gz 41285 SHA256 159b42451e4018d9da97994f4ac46d5166abf9b6f343db30071c8fd1cfe0c7c2 SHA512 e4667a3294a6a9d4b2a35e1c6dcc2b52db92589f3060e69fc7d4a4cad604dd2484341156b2cfeabdb4f70b777b687297be93b84a33838eb9622b734569ae9b33 WHIRLPOOL 7d9222e59d5e11dc3e0c9574c712176da407787050308a24491b808c3b90463c2696ce5251518612bfc7c40161129b130ae58e3c35fee0ad6dc0c1ded4bc0da7
+DIST Test-Deep-1.127.tar.gz 41606 SHA256 b78cfc59c41ba91f47281e2c1d2bfc4b3b1b42bfb76b4378bc88cc37b7af7268 SHA512 d8cf3c495d62b6cbe01628115daed0a131ba330645a77074867740ffb7420cf261f2da0da62613e4fdbaab40167e6a77668a7f772e885038427518711a0ab4d7 WHIRLPOOL 2c49e54553c25c2da0b7922a4c1884c0eb045c8bbff3b77fba40a83c4d4e936bf1bbbc9c8b8e977c9627fbdfe5612aa193fa48ad4e23ab069b29ff27d02de82c
diff --git a/dev-perl/Test-Deep/Test-Deep-1.127.0.ebuild b/dev-perl/Test-Deep/Test-Deep-1.127.0.ebuild
new file mode 100644
index 000000000000..3faea05b69f1
--- /dev/null
+++ b/dev-perl/Test-Deep/Test-Deep-1.127.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+DIST_AUTHOR=RJBS
+DIST_VERSION=1.127
+inherit perl-module
+
+DESCRIPTION="Extremely flexible deep comparison testing"
+
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+IUSE="test"
+
+RDEPEND="
+ >=virtual/perl-Scalar-List-Utils-1.90.0
+ virtual/perl-Test-Simple
+"
+DEPEND="${RDEPEND}
+ virtual/perl-ExtUtils-MakeMaker
+ test? (
+ >=virtual/perl-Test-Simple-0.880.0
+ )
+"
+
+src_test() {
+ # Bug 584238 Avoidance
+ if perl -e 'exit ( eval { require Test::Tester; Test::Tester->VERSION(0.04); 1 } ? 0 : 1 )'; then
+ perl-module_src_test
+ else
+ einfo "Test phase skipped: Test::Tester required for tests"
+ einfo "Please upgrade to >=dev-lang/perl-5.22.0 or >=virtual/perl-Test-Simple-1.1.10"
+ einfo "if you want this tested"
+ fi
+}