summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBrian Evans <grknight@gentoo.org>2016-12-19 14:13:56 -0500
committerBrian Evans <grknight@gentoo.org>2016-12-19 14:13:56 -0500
commitbb87221e74450d456e3e152f4b0c01dfe7b97c99 (patch)
tree23c44f554f705a7f83dd25af01ccc15588c31f5f /dev-php/pecl-mailparse/pecl-mailparse-2.1.6-r4.ebuild
parentsci-mathematics/coq: add missing findlib build dep, bug #603126 (diff)
downloadgentoo-bb87221e74450d456e3e152f4b0c01dfe7b97c99.tar.gz
gentoo-bb87221e74450d456e3e152f4b0c01dfe7b97c99.tar.bz2
gentoo-bb87221e74450d456e3e152f4b0c01dfe7b97c99.zip
dev-php/pecl-mailparse: Version bump, cleaning dependencies
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/pecl-mailparse/pecl-mailparse-2.1.6-r4.ebuild')
-rw-r--r--dev-php/pecl-mailparse/pecl-mailparse-2.1.6-r4.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-php/pecl-mailparse/pecl-mailparse-2.1.6-r4.ebuild b/dev-php/pecl-mailparse/pecl-mailparse-2.1.6-r4.ebuild
new file mode 100644
index 000000000000..ae4d7de88091
--- /dev/null
+++ b/dev-php/pecl-mailparse/pecl-mailparse-2.1.6-r4.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PHP_EXT_NAME="mailparse"
+PHP_EXT_ECONF_ARGS=""
+DOCS=( README )
+
+USE_PHP="php5-6 php7-0 php7-1"
+
+inherit php-ext-pecl-r3
+
+USE_PHP="php5-6"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DESCRIPTION="PHP extension for parsing RFC822 and RFC2045 (MIME) messages"
+LICENSE="PHP-2.02"
+SLOT="0"
+IUSE=""
+
+RDEPEND="php_targets_php5-6? ( dev-lang/php:5.6[unicode] )"
+DEPEND="${RDEPEND}
+ dev-util/re2c"
+PDEPEND="
+php_targets_php7-0? ( dev-php/pecl-mailparse:7[php_targets_php7-0] )
+php_targets_php7-1? ( dev-php/pecl-mailparse:7[php_targets_php7-1] )
+"
+
+src_prepare() {
+ if use php_targets_php5-6 ; then
+ php-ext-source-r3_src_prepare
+ else
+ eapply_user
+ fi
+}
+
+src_install() {
+ if use php_targets_php5-6 ; then
+ php-ext-pecl-r3_src_install
+ fi
+}