summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Orlitzky <mjo@gentoo.org>2017-05-04 08:05:12 -0400
committerMichael Orlitzky <mjo@gentoo.org>2017-05-04 08:27:57 -0400
commit7bed29d1e37576754311964464ded57ef9b40ed4 (patch)
treeb1295bc0fd166c5df54111dacae0397a08edbf13 /dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild
parentdev-util/drone: Update config and user home (diff)
downloadgentoo-7bed29d1e37576754311964464ded57ef9b40ed4.tar.gz
gentoo-7bed29d1e37576754311964464ded57ef9b40ed4.tar.bz2
gentoo-7bed29d1e37576754311964464ded57ef9b40ed4.zip
dev-php/sebastian-diff: new revision to fix autoloader class names.
Two of the class names in this package's autoload.php were in error: they were named after the filename, instead of the classes that they actually contain (perhaps this is a bug upstream?). In any case, the PHPUnit test suite for symfony-finder was failing looking for a class that it couldn't find. The new revision should force users to install the updated autoload.php. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild')
-rw-r--r--dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild b/dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild
new file mode 100644
index 000000000000..c1d9a3ad1779
--- /dev/null
+++ b/dev-php/sebastian-diff/sebastian-diff-1.4.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+MY_PN="diff"
+
+DESCRIPTION="PHP Diff implementation"
+HOMEPAGE="http://phpunit.de"
+SRC_URI="https://github.com/sebastianbergmann/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ppc ~ppc64 ~x86"
+IUSE=""
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RDEPEND="dev-php/fedora-autoloader
+ >=dev-lang/php-5.6:*"
+
+src_install() {
+ insinto /usr/share/php/SebastianBergmann/Diff
+ doins -r src/*
+ doins "${FILESDIR}/autoload.php"
+}