summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-07 03:45:31 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-07 03:55:46 +0200
commit2391686e33f3410239c3eaf0cf95a1b1f447e4ed (patch)
tree05c589acd3469d97fdd2bd656b97fe8b9657e71b /dev-python/Faker
parentdev-python/tornado: Bump to 6.4.1 (diff)
downloadgentoo-2391686e33f3410239c3eaf0cf95a1b1f447e4ed.tar.gz
gentoo-2391686e33f3410239c3eaf0cf95a1b1f447e4ed.tar.bz2
gentoo-2391686e33f3410239c3eaf0cf95a1b1f447e4ed.zip
dev-python/Faker: Bump to 25.6.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-25.6.0.ebuild41
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-25.6.0.ebuild b/dev-python/Faker/Faker-25.6.0.ebuild
new file mode 100644
index 000000000000..4c2a8812f280
--- /dev/null
+++ b/dev-python/Faker/Faker-25.6.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2022-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYPI_NO_NORMALIZE=1
+PYTHON_COMPAT=( pypy3 python3_{10..13} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ local -x PYTEST_PLUGINS=faker.contrib.pytest.plugin
+ epytest
+}
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index e44afd278cc7..3302f6e5c23a 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,3 +1,4 @@
DIST Faker-25.2.0.tar.gz 1760547 BLAKE2B cba47dd21caaabef23212d38b856c67d9d68c6478f44269ed0da7df4aa06cd313caef1d8072572c2b680172e6a6313548228cbd446e397b6e29fd3e5317bc707 SHA512 bec0a516944f36a4714bcb9b8d46dbd4ab3fb3feb6d4818fd28e9d22d0cfd1621845f669940d41365ec423398ef58714e18de5ae537ce7524cf27018ab088c8f
DIST Faker-25.3.0.tar.gz 1760396 BLAKE2B 46e12f80a84385b4bb50e19a26fe436be1ee846f87309869bc624ec45c15550f33e733d70d9e87c493521020c4e16cddb6f17f2bbc36b6d8072829f582f0beed SHA512 d4b3a762d22b9947ebae254d07abc7e0c3511d9277439075fe876371f1c25dbcbe5a08729e33925c98ec86ef3b5f3321b5a3ac3802784bb42f8296fe9a09eb30
DIST Faker-25.4.0.tar.gz 1760724 BLAKE2B c081bac6264721bafb80c8c64d85050dddfcc89a47f84c1e31ddc8980919c9f46cce0eec00c63f5af906ae09f4e55782610e6a216e481b784a733d9d15385815 SHA512 90398d9ba91d54eb5f81794a7df3b2131206eeff37105653e8175226ad82ef63ac365a9e5fa32f1fb0f30cdf398811e72ac22c2eefc6f2e8ff0821180a362186
+DIST Faker-25.6.0.tar.gz 1761114 BLAKE2B ed88ab6f3bd86ae29bce97318a693b5045a0a688e09b3266b32d217d04c66805bae30f809fc3e384cefc8e7d44e172908cb156c7ce3c43fe68505f47a89c5ffd SHA512 6048a7d225b6cbf4c5e2b11c4d33eeef2eb22414345310907180723e93688d11c885c168bf6d67dd253bd992856e5b41d2921d5673c9ce674cd6d5dd3f81e299