summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-11-30 21:24:21 +0200
committerArthur Zamarin <arthurzam@gentoo.org>2022-11-30 21:41:57 +0200
commit909a7f1924526598d7da4ae3d8778917cee53900 (patch)
treea93f7023d3daf9bf2b3a54808930b152828d3be6 /dev-python/Faker
parentdev-python/ytmusicapi: add 0.24.1 (diff)
downloadgentoo-909a7f1924526598d7da4ae3d8778917cee53900.tar.gz
gentoo-909a7f1924526598d7da4ae3d8778917cee53900.tar.bz2
gentoo-909a7f1924526598d7da4ae3d8778917cee53900.zip
dev-python/Faker: add 15.3.4
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/Faker')
-rw-r--r--dev-python/Faker/Faker-15.3.4.ebuild34
-rw-r--r--dev-python/Faker/Manifest1
2 files changed, 35 insertions, 0 deletions
diff --git a/dev-python/Faker/Faker-15.3.4.ebuild b/dev-python/Faker/Faker-15.3.4.ebuild
new file mode 100644
index 000000000000..7547e146fdbe
--- /dev/null
+++ b/dev-python/Faker/Faker-15.3.4.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package that generates fake data for you"
+HOMEPAGE="
+ https://github.com/joke2k/faker/
+ https://pypi.org/project/Faker/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/python-dateutil-2.4.2[${PYTHON_USEDEP}]
+ !dev-ruby/faker
+"
+BDEPEND="
+ test? (
+ dev-python/freezegun[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},tiff]
+ dev-python/validators[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
diff --git a/dev-python/Faker/Manifest b/dev-python/Faker/Manifest
index 576c5955a861..8d01b80088e1 100644
--- a/dev-python/Faker/Manifest
+++ b/dev-python/Faker/Manifest
@@ -1,3 +1,4 @@
DIST Faker-15.3.1.tar.gz 1598695 BLAKE2B 8c9d8ec18cf8505eb3ca00feb0e7cea78db2f6f5b8dd4b0a65cc600b0cf57a96c174a6f0f2f99f67dab873ad6afc63f858b5f0efe672583d055eb69d59a86104 SHA512 8dce318ee0e8959b7f7da4b5fda792476a7b4f8bc22a2acead29131e0f6c97fb0b84522cc2865264276f65606e8559ae3213f4671e4c701301845986920ecf9d
DIST Faker-15.3.2.tar.gz 1598951 BLAKE2B 6f1c53933639a478aa6db933b26e326561b654cbb3d7182c7d8b1add50aaa4089ebf001553e95657baa2f434516148e40417c0265043d2a50f8e86c73556f82f SHA512 96489fd02cc16ff0a31a0f165805aa4508e2f3e04552f2008b92f211c8645e37ee23a8181838f851114906e2df0da19a95c38889e6afab5d1c7cf090a9235e17
DIST Faker-15.3.3.tar.gz 1598995 BLAKE2B c6416f06b835b153a2e72967a4b65b962068d027dc35a95ebdd92175f8e6330ef07f3721ca5d6ba4bb85efdc54ecedf0663f458ec8fcedd489e2871c623af3de SHA512 371516d95941921f5180107beba633a40df719a38f6b752f38857be15ae7befcb602c1b3f16ccbbaa7e8aa2c6b158c70aea38a112d65234d334ce1f370c91b87
+DIST Faker-15.3.4.tar.gz 1599191 BLAKE2B 8fc26d35cbcde467123c8a5e15813351e65cf81a3640552115bdc55dff48b123e28b180e46595b80029dfdc0d3545b9e75b3f8c2deff380a6168aa2ab603ef2f SHA512 f9c50008c492a2aa8a7d7e62d0f404036cc9161baa3036f5948f607d4e971b34945401f565b3640eca71e7716fa5f2f3d82dd029f84f35dd4925e647638c0c56