summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2024-04-20 10:34:40 -0400
committerIonen Wolkens <ionen@gentoo.org>2024-04-20 10:34:40 -0400
commitdb02edc60e4b4340920f960952e2b3f67977700b (patch)
tree664e37ed3cf67f3321f23743c68a30886f6b25f7 /dev-python/PyQt-builder/PyQt-builder-1.16.1.ebuild
parentdev-python/PyQt-builder: drop 1.15.4 (diff)
downloadgentoo-db02edc60e4b4340920f960952e2b3f67977700b.tar.gz
gentoo-db02edc60e4b4340920f960952e2b3f67977700b.tar.bz2
gentoo-db02edc60e4b4340920f960952e2b3f67977700b.zip
dev-python/PyQt-builder: add 1.16.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'dev-python/PyQt-builder/PyQt-builder-1.16.1.ebuild')
-rw-r--r--dev-python/PyQt-builder/PyQt-builder-1.16.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/PyQt-builder/PyQt-builder-1.16.1.ebuild b/dev-python/PyQt-builder/PyQt-builder-1.16.1.ebuild
new file mode 100644
index 000000000000..f7104b76fd44
--- /dev/null
+++ b/dev-python/PyQt-builder/PyQt-builder-1.16.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+inherit distutils-r1 pypi
+
+DESCRIPTION="The PEP 517 compliant PyQt build system"
+HOMEPAGE="https://github.com/Python-PyQt/PyQt-builder/"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/sip-6.7[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"
+
+src_prepare() {
+ distutils-r1_src_prepare
+
+ # don't install prebuilt DLLs
+ rm -r pyqtbuild/bundle/dlls || die
+}