summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-06-11 21:14:40 +0200
committerMichał Górny <mgorny@gentoo.org>2023-06-11 21:19:03 +0200
commit8981b938014c7d45ca878bb352b5f6c7d9480779 (patch)
tree540862770f99cda32a98a572858a475a41e89d85 /dev-python/aesara
parentxfce-extra/xfce4-weather-plugin: Remove old (diff)
downloadgentoo-8981b938014c7d45ca878bb352b5f6c7d9480779.tar.gz
gentoo-8981b938014c7d45ca878bb352b5f6c7d9480779.tar.bz2
gentoo-8981b938014c7d45ca878bb352b5f6c7d9480779.zip
dev-python/aesara: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/aesara')
-rw-r--r--dev-python/aesara/Manifest1
-rw-r--r--dev-python/aesara/aesara-2.8.12.ebuild111
2 files changed, 0 insertions, 112 deletions
diff --git a/dev-python/aesara/Manifest b/dev-python/aesara/Manifest
index 580819da6bd7..6d1da7e65614 100644
--- a/dev-python/aesara/Manifest
+++ b/dev-python/aesara/Manifest
@@ -1,2 +1 @@
DIST aesara-2.9.0.tar.gz 4421520 BLAKE2B e0c1cc0c48313c84c1ebe99e04e9d097bd37d63f7948b81df77538d647853233378aa2f2b985c1ab6e7f22adf47abef243addadad3505f332e465e1569d31e17 SHA512 2f36e5f462dc3dc36a0f7d7e99b01ae2be5091c2e6127d1f079245b104ce21cee7afff4dc4ade403e2e8a0dffa5feda2e0e9d4bd734192350672c85c36390c4b
-DIST aesara-rel-2.8.12.gh.tar.gz 4582575 BLAKE2B d212e41fd22b54335bcc6f7a744d51113b1cfbad011480eabfde1b72cef5955ce019f2ee2a821d4cea22aa4340a2537156e3f4a5a1962ae0f23107d20df3d70a SHA512 c65e63efa1d6e9de0df6db6f96226d6f830198626a3dc7e77a977e3260ab276745b9c8ae5fa9ea48edb9aee9d88c8181e7a7e19aaa49e51290e4df619e227bbf
diff --git a/dev-python/aesara/aesara-2.8.12.ebuild b/dev-python/aesara/aesara-2.8.12.ebuild
deleted file mode 100644
index f171c4c867e9..000000000000
--- a/dev-python/aesara/aesara-2.8.12.ebuild
+++ /dev/null
@@ -1,111 +0,0 @@
-# Copyright 2021-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=hatchling
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1 multiprocessing optfeature
-
-MY_P=aesara-rel-${PV}
-DESCRIPTION="Library for operating on mathematical expressions with multi-dimensional arrays"
-HOMEPAGE="
- https://github.com/aesara-devs/aesara/
- https://pypi.org/project/aesara/
-"
-SRC_URI="
- https://github.com/aesara-devs/aesara/archive/rel-${PV}.tar.gz
- -> ${MY_P}.gh.tar.gz
-"
-S=${WORKDIR}/${MY_P}
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="amd64 ~arm ~arm64 ~riscv x86"
-
-RDEPEND="
- dev-python/cons[${PYTHON_USEDEP}]
- dev-python/etuples[${PYTHON_USEDEP}]
- dev-python/logical-unification[${PYTHON_USEDEP}]
- dev-python/minikanren[${PYTHON_USEDEP}]
- dev-python/filelock[${PYTHON_USEDEP}]
- dev-python/numpy[${PYTHON_USEDEP}]
- dev-python/scipy[${PYTHON_USEDEP}]
- dev-python/typing-extensions[${PYTHON_USEDEP}]
-"
-BDEPEND="
- dev-python/hatch-vcs[${PYTHON_USEDEP}]
- test? (
- dev-python/pytest-xdist[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=(
- "${FILESDIR}"/aesara-2.6.5-compiledir-tid.patch
- "${FILESDIR}"/aesara-2.8.10-fix-tuple.patch
-)
-
-distutils_enable_tests pytest
-
-src_prepare() {
- # do not claim "bin" package (sic!)
- rm bin/__init__.py || die
- distutils-r1_src_prepare
-}
-
-python_test() {
- local EPYTEST_DESELECT=(
- # speed tests are unreliable
- tests/scan/test_basic.py::test_speed
- tests/scan/test_basic.py::test_speed_rnn
- tests/scan/test_basic.py::test_speed_batchrnn
- tests/link/test_vm.py::test_speed
- tests/link/test_vm.py::test_speed_lazy
- tests/tensor/test_gc.py::test_merge_opt_runtime
-
- # rounding problem?
- # https://github.com/aesara-devs/aesara/issues/477
- tests/tensor/test_math_scipy.py::TestGammaUBroadcast::test_good
- tests/tensor/test_math_scipy.py::TestGammaUInplaceBroadcast::test_good
-
- # Deprecation warning causes unexpected additional output
- tests/tensor/test_basic.py::TestLongTensor::test_fit_int64
-
- # dunno
- tests/tensor/test_elemwise.py::TestDimShuffle::test_memory_leak
- tests/tensor/signal/test_pool.py::TestDownsampleFactorMax::test_DownsampleFactorMaxGradGrad_grad
-
- # TODO
- tests/link/c/test_op.py::test_ExternalCOp_c_code_cache_version
- tests/sparse/sandbox/test_sp.py::TestSP::test_multilayer_conv
- tests/sparse/sandbox/test_sp.py::TestSP::test_maxpool
-
- # TODO: Package pytest-benchmark
- tests/scan/test_basic.py::TestExamples::test_reordering
- tests/scan/test_basic.py::TestExamples::test_scan_as_tensor_on_gradients
- tests/scan/test_basic.py::TestExamples::test_multiple_outs_taps
- tests/scan/test_rewriting.py::TestPushOutAddScan::test_pregreedy_optimizer
- tests/scan/test_rewriting.py::TestSaveMem::test_savemem_opt
- tests/scan/test_basic.py::test_cython_performance
- )
- local EPYTEST_IGNORE=(
- # we do not package jax or numba
- tests/link/jax
- tests/link/numba
- )
-
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x AESARA_FLAGS="cxx=${CXX}"
- AESARA_FLAGS+=",config.gcc__cxxflags=\"${CXXFLAGS}\""
- AESARA_FLAGS+=',compiledir_format="compiledir_%(thread_id)s"'
-
- epytest -p xdist.plugin -n "$(makeopts_jobs)"
- # clean up the compiledir, as it can grow pretty large
- rm -r "${HOME}"/.aesara || die
-}
-
-pkg_postinst() {
- optfeature "GPU code generation/execution on NVIDIA gpus" dev-util/nvidia-cuda-toolkit
- optfeature "GPU/CPU code generation on CUDA and OpenCL devices" dev-libs/libgpuarray dev-python/pycuda
-}