summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-10-18 06:38:46 +0200
committerMichał Górny <mgorny@gentoo.org>2023-10-18 07:05:52 +0200
commite75c7cd98055b6b3d43005d6a8e5dd2145a387a9 (patch)
tree64ebb6e43daaee3c00692bbe96db75a3c3d2aaba /dev-python/agate
parentapp-admin/awscli: Bump to 1.29.65 (diff)
downloadgentoo-e75c7cd98055b6b3d43005d6a8e5dd2145a387a9.tar.gz
gentoo-e75c7cd98055b6b3d43005d6a8e5dd2145a387a9.tar.bz2
gentoo-e75c7cd98055b6b3d43005d6a8e5dd2145a387a9.zip
dev-python/agate: Bump to 1.9.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/agate')
-rw-r--r--dev-python/agate/Manifest1
-rw-r--r--dev-python/agate/agate-1.9.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/agate/Manifest b/dev-python/agate/Manifest
index d0d18f5951e0..5f6c407787c5 100644
--- a/dev-python/agate/Manifest
+++ b/dev-python/agate/Manifest
@@ -1,2 +1,3 @@
DIST agate-1.7.1.tar.gz 202018 BLAKE2B 9df0f108f1ac47c1eb199015aedc903d72ce62a7d2c34198f0f287863527a2305c5682ef7dd385d130fd0eb3ce566e98978b9ef438858510e3aeae02a6345318 SHA512 e40df26f1e738b4c386f540d642f4fdb240dac5229032c6074977a67c7fdae7838c770703d93916e10741a9f2569ac9672165f8c8715b2567b2e5b926c7dabd5
DIST agate-1.8.0.tar.gz 201730 BLAKE2B c0138f912d6981059b8cd62424bdb428c9b6bff566bc47466bea9f0fd78f100333583dddaf081ea2f9810e8a1e586d4697960141ea4e97e8cef4a5084f09ce78 SHA512 9870f31f87efcb057947cf0c93062c2dbfa2aa996d1e6d69c552935eca3ab5c047ea0cbdf2eaca8e37d2a0530d210318fd342324f1ce43d7cba9f6291206f6fb
+DIST agate-1.9.0.tar.gz 202237 BLAKE2B f4a6609f843b0b0499b44c6596c186198e2d6a0c964727fbd3d3fa69bd6164a067384354e3426a0276f91fc3b6f2d1fc86e05e4d4be974d1f2c223b20cb5a6b3 SHA512 bbd05b503d27e34625cebba71c0d3a1362bf63c45a3ce7c327fb73f0730b739fe8f9bf780c37c4e1a0e70c9d263d9191946fa6b70c147c0761a43ed479ae7fed
diff --git a/dev-python/agate/agate-1.9.0.ebuild b/dev-python/agate/agate-1.9.0.ebuild
new file mode 100644
index 000000000000..bf35fa27a14c
--- /dev/null
+++ b/dev-python/agate/agate-1.9.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2021-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..11} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A Python data analysis library that is optimized for humans instead of machines"
+HOMEPAGE="
+ https://github.com/wireservice/agate/
+ https://pypi.org/project/agate/
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~arm64-macos ~x64-macos"
+
+RDEPEND="
+ >=dev-python/pytimeparse-1.1.5[${PYTHON_USEDEP}]
+ >=dev-python/parsedatetime-2.1[${PYTHON_USEDEP}]
+ >=dev-python/Babel-2.0[${PYTHON_USEDEP}]
+ >=dev-python/isodate-0.5.4[${PYTHON_USEDEP}]
+ >=dev-python/pyicu-2.4.2[${PYTHON_USEDEP}]
+ >=dev-python/python-slugify-1.2.1[${PYTHON_USEDEP}]
+ >=dev-python/leather-0.3.3-r2[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/lxml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/furo
+
+EPYTEST_DESELECT=(
+ # require specific locales
+ tests/test_data_types.py::TestDate::test_cast_format_locale
+ tests/test_data_types.py::TestDateTime::test_cast_format_locale
+)