summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPetr Vaněk <arkamar@atlas.cz>2023-06-07 10:48:25 +0200
committerSam James <sam@gentoo.org>2023-06-07 10:26:58 +0100
commit347973cbe734396089c895e940cb8044dd1ca40f (patch)
treed50a6db2811589ffdc5f69eff4183bae1dbad023 /dev-python/alembic
parentdev-python/python-editor: enable py3.12 (diff)
downloadgentoo-347973cbe734396089c895e940cb8044dd1ca40f.tar.gz
gentoo-347973cbe734396089c895e940cb8044dd1ca40f.tar.bz2
gentoo-347973cbe734396089c895e940cb8044dd1ca40f.zip
dev-python/alembic: enable py3.12
Signed-off-by: Petr Vaněk <arkamar@atlas.cz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/alembic')
-rw-r--r--dev-python/alembic/alembic-1.11.1.ebuild8
1 files changed, 7 insertions, 1 deletions
diff --git a/dev-python/alembic/alembic-1.11.1.ebuild b/dev-python/alembic/alembic-1.11.1.ebuild
index 8abd48cc9bb7..0fb0d2348c60 100644
--- a/dev-python/alembic/alembic-1.11.1.ebuild
+++ b/dev-python/alembic/alembic-1.11.1.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..11} )
+PYTHON_COMPAT=( pypy3 python3_{10..12} )
inherit distutils-r1 pypi
@@ -29,6 +29,12 @@ RDEPEND="
distutils_enable_tests pytest
+python_test() {
+ # setup.cfg contains -p no:warnings in addopts which triggers
+ # datetime.utcfromtimestamp() deprecation warning as an error in py3.12
+ epytest -o addopts=
+}
+
python_install_all() {
use doc && local HTML_DOCS=( docs/. )
distutils-r1_python_install_all