summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-27 23:34:12 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-28 00:16:07 +0200
commitcc0d7797c5597768458915f622b48b186c06c436 (patch)
tree63bed83bc1ec28d86dfd94746fcc0b6abbe45b19 /dev-python/apispec
parentdev-python/apispec: Remove old (diff)
downloadgentoo-cc0d7797c5597768458915f622b48b186c06c436.tar.gz
gentoo-cc0d7797c5597768458915f622b48b186c06c436.tar.bz2
gentoo-cc0d7797c5597768458915f622b48b186c06c436.zip
dev-python/apispec: Bump to 5.1.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/apispec')
-rw-r--r--dev-python/apispec/Manifest1
-rw-r--r--dev-python/apispec/apispec-5.1.1.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/apispec/Manifest b/dev-python/apispec/Manifest
index 2f19f6f44d7e..632b5e9b5d12 100644
--- a/dev-python/apispec/Manifest
+++ b/dev-python/apispec/Manifest
@@ -1 +1,2 @@
DIST apispec-5.1.0.gh.tar.gz 69990 BLAKE2B 0fc488abae9657c9996775c460b97b66a782b82012bf3c1bb6a1623600b03c71bc80eb556d60720e00b07551a5c3b44b40f709bffbb05b10603485af9122cd6b SHA512 ebcb6ddc71be541c152f18eaf2462f09c5860b689d34581723dc8f70f4da59966c34ea6f1282be2ea38cb4524af224a96bcfe974f5fcc62bf4939c644aa6df48
+DIST apispec-5.1.1.gh.tar.gz 70296 BLAKE2B 339706890d23c796ea73c23735c5655694315a8a8017eba8f69574ed4e85ddf9a65c3a26482a78f08a118afd19e3c9bbcc9d264bb770941d7affbf7cf85eb925 SHA512 4e0e2959699c735c5242aa1a954392d97ea4809aafbd8d091f608baf7397a31964852588c474acb84e8755a62849837d741eb1e5fdf1cd5304f46c852e346d03
diff --git a/dev-python/apispec/apispec-5.1.1.ebuild b/dev-python/apispec/apispec-5.1.1.ebuild
new file mode 100644
index 000000000000..990b59d0c9d9
--- /dev/null
+++ b/dev-python/apispec/apispec-5.1.1.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="A pluggable API specification generator."
+HOMEPAGE="https://github.com/marshmallow-code/apispec/"
+SRC_URI="
+ https://github.com/marshmallow-code/apispec/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ >=dev-python/pyyaml-3.10[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ dev-python/bottle[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ >=dev-python/marshmallow-3.13.0[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+distutils_enable_sphinx docs \
+ dev-python/sphinx-issues \
+ dev-python/sphinx_rtd_theme
+
+EPYTEST_DESELECT=(
+ # requires unpackaged prance
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v2
+ tests/test_ext_marshmallow_openapi.py::test_openapi_tools_validate_v3
+)