summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-09-17 10:14:00 +0200
committerMichał Górny <mgorny@gentoo.org>2020-09-17 10:34:18 +0200
commit3a6db1a7e376cdf193ad93c8768cdb3e9cbfa182 (patch)
tree98a16888166ddf36b7644e1168900f6d56f7a4dd /dev-python/bleach
parentapp-eselect/eselect-java: bump to 0.4.2 (diff)
downloadgentoo-3a6db1a7e376cdf193ad93c8768cdb3e9cbfa182.tar.gz
gentoo-3a6db1a7e376cdf193ad93c8768cdb3e9cbfa182.tar.bz2
gentoo-3a6db1a7e376cdf193ad93c8768cdb3e9cbfa182.zip
dev-python/bleach: Bump to 3.2.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/bleach')
-rw-r--r--dev-python/bleach/Manifest1
-rw-r--r--dev-python/bleach/bleach-3.2.0.ebuild38
2 files changed, 39 insertions, 0 deletions
diff --git a/dev-python/bleach/Manifest b/dev-python/bleach/Manifest
index 495386a6fe98..95124802e073 100644
--- a/dev-python/bleach/Manifest
+++ b/dev-python/bleach/Manifest
@@ -1 +1,2 @@
DIST bleach-3.1.5.tar.gz 177972 BLAKE2B 6033871f757247f05ee67f66b3596c7a76a9bc5105113206bc8749f9ed103fb6a7c91630540f5f17ddc17e261b24043cc2edcc2562ea7f4cf54774080854de32 SHA512 20db9ab6924a1e884107f30e1059f774b45fd169d3965a61a4ff028e3de17e30be81474d7da89d9275b2173a005c5504a9d11f0e0ca528bf36a9bf08aeed0607
+DIST bleach-3.2.0.tar.gz 178910 BLAKE2B e7e97cc367420a656086e5a0e6c1c527348a0edc23c15f5f4b5a40b3079a2fa32b71fd2d99c4db8891e1b2ed06e4ac8ab3d3f0c9a3de77d02499bf32746a9dd7 SHA512 06dd7e22204280a03e37cfc303b4de8fc8776e9ac3f7a4c2451f1ff768b68d97c6b00fa42dc275eb4404dae5e448b9385b4e6ee204fdc7e11f31207cdc3d926a
diff --git a/dev-python/bleach/bleach-3.2.0.ebuild b/dev-python/bleach/bleach-3.2.0.ebuild
new file mode 100644
index 000000000000..eab1404c49f4
--- /dev/null
+++ b/dev-python/bleach/bleach-3.2.0.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6..9} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="an easy whitelist-based HTML-sanitizing tool"
+HOMEPAGE="https://github.com/mozilla/bleach https://pypi.org/project/bleach/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="test"
+
+RDEPEND="
+ dev-python/packaging[${PYTHON_USEDEP}]
+ >=dev-python/html5lib-1.0.1-r1[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/webencodings[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/bleach-3.1.5-py39.patch
+)
+
+src_prepare() {
+ # unbundle unpatched broken html5lib
+ rm -r bleach/_vendor || die
+ sed -i -e 's:bleach\._vendor\.::' \
+ bleach/html5lib_shim.py tests/test_clean.py || die
+
+ distutils-r1_src_prepare
+}