summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-05-24 04:36:07 +0200
committerMichał Górny <mgorny@gentoo.org>2024-05-24 06:02:53 +0200
commit13b9b112b5ca56ac7352a2f7d654cd32f621d924 (patch)
tree15e3ce6fb09b04abbd9f6f0808fd8a88cd048354 /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.112 (diff)
downloadgentoo-13b9b112b5ca56ac7352a2f7d654cd32f621d924.tar.gz
gentoo-13b9b112b5ca56ac7352a2f7d654cd32f621d924.tar.bz2
gentoo-13b9b112b5ca56ac7352a2f7d654cd32f621d924.zip
dev-python/boto3: Bump to 1.34.112
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.112.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 60bf65056572..eb82eff77879 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -4,4 +4,5 @@ DIST boto3-1.34.108.gh.tar.gz 809808 BLAKE2B 56d21fdc35917426ea94f27ee4c7a59bc9e
DIST boto3-1.34.109.gh.tar.gz 810229 BLAKE2B 7d0af8783283715d281df2e68284aa98ead02c764892ec53bdff5212b470c561da4a52b94c62936a20d36a1bd32dac560a38e59577b34d9f82bbee197491e94b SHA512 f35cfb8cbab03c0c6856c01f095cf593c188ab81c8f9bd9c7f9d4e3ca654204795d19810ed701d31ee48f0a34ae1d47437b64ea5f7090708976e7d883677440f
DIST boto3-1.34.110.gh.tar.gz 811067 BLAKE2B 5c030d0a52081a2e931c85611b510558c79a3079d3aa445b82bf2421424c00076f6f0d415dbec838cd437e680470652245595ec8a83e835eba3480f147f12a45 SHA512 e0780b1cca01503d730f01423cbab369cc0c4de8fd2e59033e64779d41c3d648aa54a8b80b6997d1ad9f2bab2673e426a3c1b5bf6536fb0f4248b0c7eade8512
DIST boto3-1.34.111.gh.tar.gz 811593 BLAKE2B 5b1ba72259c6cf995e4a3668e6b4e195e9bfcfa6b3b0fb992795f98da301c1982196e3af1adfda355a4b73fb418158bc737524e8d220303af3c3fd28c65e2ff0 SHA512 7d0735a6beb3ba7d3e2c4eba4023d5f291aa522c1ea3947c37f29ae235e69ac02847bda7c4e9cd694d6e89fe3bf0e56b1cd41a4fed40b8924670b240c8643f98
+DIST boto3-1.34.112.gh.tar.gz 811766 BLAKE2B 7772298d455654a6d4ae1c0ccb7819ad14232638d465c5b4b95db4a352f0bced80f3b85c85638de3a0a1b9068453f594ebc804b2ab0508027eb0e5bc2af5ac83 SHA512 b75aab26264f35ea6df41e4dcbb303750210f56b33dbb95049585bab8c0b84d78d2f1a6efac854c5da37ee2d5088594e8aad00944db8c79551ef864b93a855bd
DIST boto3-1.34.98.gh.tar.gz 805719 BLAKE2B 5cf7f0cc415e25c8b41aa464b636b1683f4e71198569f5eac3e6e43cef7050e20e92c3fd988517fc1463601073b41b0b9c668a58bb866d03b83973c9b9cd976a SHA512 06cab81bbf73a9c37b68e0312a7c587bace700b8032e283b6782c1275804ea7c93065c4282837957b5cf3523d50fe57319a54af494262e2666f65440da9771fd
diff --git a/dev-python/boto3/boto3-1.34.112.ebuild b/dev-python/boto3/boto3-1.34.112.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.112.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}