summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-02-15 04:04:11 +0100
committerMichał Górny <mgorny@gentoo.org>2024-02-15 04:04:11 +0100
commit9e16d264625487f9d2b20767c4747d46106e1c29 (patch)
tree2ee7b28b7a54852306efdc7cc2ba0d36c11bdef8 /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.42 (diff)
downloadgentoo-9e16d264625487f9d2b20767c4747d46106e1c29.tar.gz
gentoo-9e16d264625487f9d2b20767c4747d46106e1c29.tar.bz2
gentoo-9e16d264625487f9d2b20767c4747d46106e1c29.zip
dev-python/boto3: Bump to 1.34.42
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.42.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 424f9e7c5d40..dd16647ad1fa 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -3,3 +3,4 @@ DIST boto3-1.34.34.gh.tar.gz 771553 BLAKE2B 52459e1baefd7986256bb6c89074aac365fb
DIST boto3-1.34.39.gh.tar.gz 773491 BLAKE2B 69256649eb3bc5a856adffe4fb1e0e3f1e14e9a8ff557a9c4a4a8009bc0b8483555e9350f98656d3088c271152db199201c2739e4860fbc0c63810e19a13eca4 SHA512 88fb84a97c072f3e1719116d10dae2a8a840f495aa89f42f13fb105209d0d098390cbdbc443811ae78a684735fa571dbe66bf10c0e53718e783a17de36a18197
DIST boto3-1.34.40.gh.tar.gz 773834 BLAKE2B 3622514c5e114a015dc7725bf7415858956e91084715a0e1342a6baacca62a1a2a453dfbe972bdf57438047b30a7729cd98f81afaf554ff8beb89eafd3920bbb SHA512 875afff65371b5991fcc1c832ddcc919dc04306ce03ddba8851e69f4138fc8698f3d21c340bb2936e9022fe0813eb90f2ac084e2531166ee21542a049bb3f1c6
DIST boto3-1.34.41.gh.tar.gz 774170 BLAKE2B ec6c60a181afa8266018f8dd58917a7277d2b405736b2af94689cd7b3af6b961799f8ba4ea1395917695673d857cb9542507daed78d5e13f9517e3bcb254e08c SHA512 2f9be9b87c2f632d9291419eccd155a13d6120e93e1966afc236405742d4a2357fe53cc5dcc9b10aaf22ffe93d2e52285e3d44d4f578b5688a08b9cb705c42f1
+DIST boto3-1.34.42.gh.tar.gz 774581 BLAKE2B af50bc64eee24b2a8e56453a1823ad008e745dcd0335d2ea2bcbf58d84311cd1b4da91bf1cdbb0ed74ea4e17fb6a278279628634f33bf2649d4c22be1251cb18 SHA512 cfee96d5da7eaeb324113baa5f52fc1f3576db74e2d5bd72345701ebdd9907a915715fff14cd0cabcffb5a790c0432177e4881eda487b0882f97d6cc2c14bc57
diff --git a/dev-python/boto3/boto3-1.34.42.ebuild b/dev-python/boto3/boto3-1.34.42.ebuild
new file mode 100644
index 000000000000..b64e7191fd19
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.42.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}