summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-19 06:10:46 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-19 06:10:46 +0200
commitb116e6d5c36c2ad768a7d2fec90d964b6cd22269 (patch)
tree25a9ba5ac6ae6c2a073ea8d28b567077c0a4955a /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.129 (diff)
downloadgentoo-b116e6d5c36c2ad768a7d2fec90d964b6cd22269.tar.gz
gentoo-b116e6d5c36c2ad768a7d2fec90d964b6cd22269.tar.bz2
gentoo-b116e6d5c36c2ad768a7d2fec90d964b6cd22269.zip
dev-python/boto3: Bump to 1.34.129
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.129.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index 38ef5442b1d6..74a0f782d79c 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -2,3 +2,4 @@ DIST boto3-1.34.117.gh.tar.gz 813596 BLAKE2B 1b68c6410a9e4859c05ec6e8baa7b4d0a8e
DIST boto3-1.34.122.gh.tar.gz 817093 BLAKE2B ecc91833d5d8b7ae33c2fe435e33bc8fa236388dcd36bbbfad138e72dcada1018d9fe032a04565bc6ba04f252c5b1e066f650620aab2b6682705d164660eaa9b SHA512 26ece26e24a09ce12f57fd7cbede798446ddb60c28dd7d090c2604b71cc92fca9cfdc268e6d65fad1bcecf161976186b21acefdb70a2de8acaccd85567a388d0
DIST boto3-1.34.127.gh.tar.gz 820740 BLAKE2B ddfb7802440a01af27059daed4bc7cd3797eb192004a0e7b78e1e56a8ff479206b4835a79bcac1db273c2936fb8dfde0ba16bebe8cbe1befeb188070bf46b2c7 SHA512 b139ad68a4ce29e84e0fa1618b97c4aea13b668521921712df74256ad61c21d2077ea216dfb4102d8f9910a8119b24509aa10a504d746bdb410fee1cecc0461c
DIST boto3-1.34.128.gh.tar.gz 821252 BLAKE2B 7f7d13106d69b54d4932a52c0d0b2803cc5131773ce9503a1fc8ea8ff3fdfb5ba5f372b2665312ce3c136f4f37889e54cd61b49eec72ac21902f379b0ec87f29 SHA512 ee46351e613c55cf720e2bf361df8bb07954a05bc9707ce20fe75390abf195674d50e4f862ed8d357397e83c7ffcc586eff396d186596e688b895deaaaf4699f
+DIST boto3-1.34.129.gh.tar.gz 821825 BLAKE2B c672b77844c366190ed1a7d3bd1621267da9db321bdf36bad3d6f4de359b560509467156a602a598b53e5f12c4442558294199185c6a6074b7c303b914b645ae SHA512 af548985020c54ff5f9838639c89daafb2d14d2da0376a541f274d4440219758610811fb71654ecf4aa59cad1e6b56c8cb4e830949d0686665ae30a99d48f3fc
diff --git a/dev-python/boto3/boto3-1.34.129.ebuild b/dev-python/boto3/boto3-1.34.129.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.129.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}