summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-06-08 06:18:02 +0200
committerMichał Górny <mgorny@gentoo.org>2024-06-08 06:18:02 +0200
commitc57398b4d030f858506a3ae8f757a92095a36710 (patch)
treea35df80121a275825bd24df95646c1ee927cc5bf /dev-python/boto3
parentdev-python/botocore: Bump to 1.34.122 (diff)
downloadgentoo-c57398b4d030f858506a3ae8f757a92095a36710.tar.gz
gentoo-c57398b4d030f858506a3ae8f757a92095a36710.tar.bz2
gentoo-c57398b4d030f858506a3ae8f757a92095a36710.zip
dev-python/boto3: Bump to 1.34.122
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/boto3')
-rw-r--r--dev-python/boto3/Manifest1
-rw-r--r--dev-python/boto3/boto3-1.34.122.ebuild53
2 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/boto3/Manifest b/dev-python/boto3/Manifest
index c2b55f7ed672..a9cafd27ede7 100644
--- a/dev-python/boto3/Manifest
+++ b/dev-python/boto3/Manifest
@@ -5,3 +5,4 @@ DIST boto3-1.34.118.gh.tar.gz 814051 BLAKE2B cad75e7e7a24db1642e743efc83fdbe7cf4
DIST boto3-1.34.119.gh.tar.gz 814478 BLAKE2B a6284483d2921805176c657ae0e4cb3b6136d73e22c8cdeb5e8dd05617b86c07c4721adc936b485fb1f15885b71cc2b9fd1fceed78d2c82773bb623e2a743bde SHA512 6fe31f127582967ef088e851b69bf5925e9ef8d117e4695f576832f8dcd2a85e588c852200b6a1c6e9b49cb17edb600c3d078d05900175898abe38c88221ab94
DIST boto3-1.34.120.gh.tar.gz 814865 BLAKE2B a21973ccd1eaf511d6b38b7b58b0dce0c4f70577f74985cefc74e61afa36e77e2776c7f20ad64dc0b728b041670911398a6e1cdcc88b5a1471a4d87201381f78 SHA512 d75e7cba82b087010447b8c5a49b70706ef2b444c0c2fbad744dcb80a16dfe298e9d98908682007ce0cedce0a20410df6e654d059b8dd87e1551bc889a37bdce
DIST boto3-1.34.121.gh.tar.gz 816291 BLAKE2B 8bff627f58c4ccbbfb0d8992032df051a67ac750babd240d641bf4243fdfaf7856c70c73641bd309586279bf090106cd0f13d55e9dabb3ef760e3a312851530c SHA512 02bb02dd0c86eaa9d26dbf367ff1b6f72c0e8a9809a3d9295f79e8721ea87567b58c39b084888e6379047c31d6268af105377c01945b1cba9210930949e5d0e8
+DIST boto3-1.34.122.gh.tar.gz 817093 BLAKE2B ecc91833d5d8b7ae33c2fe435e33bc8fa236388dcd36bbbfad138e72dcada1018d9fe032a04565bc6ba04f252c5b1e066f650620aab2b6682705d164660eaa9b SHA512 26ece26e24a09ce12f57fd7cbede798446ddb60c28dd7d090c2604b71cc92fca9cfdc268e6d65fad1bcecf161976186b21acefdb70a2de8acaccd85567a388d0
diff --git a/dev-python/boto3/boto3-1.34.122.ebuild b/dev-python/boto3/boto3-1.34.122.ebuild
new file mode 100644
index 000000000000..2c733040b7a3
--- /dev/null
+++ b/dev-python/boto3/boto3-1.34.122.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="The AWS SDK for Python"
+HOMEPAGE="
+ https://github.com/boto/boto3/
+ https://pypi.org/project/boto3/
+"
+SRC_URI="
+ https://github.com/boto/boto3/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=dev-python/botocore-${PV}[${PYTHON_USEDEP}]
+ >=dev-python/jmespath-0.7.1[${PYTHON_USEDEP}]
+ >=dev-python/s3transfer-0.10.0[${PYTHON_USEDEP}]
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # don't lock versions to narrow ranges
+ sed -e '/botocore/ d' \
+ -e '/jmespath/ d' \
+ -e '/s3transfer/ d' \
+ -i setup.py || die
+
+ # do not rely on bundled deps in botocore (sic!)
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}