summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-10 09:32:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-10 10:01:48 +0200
commit069a8f4f1d2440cb64d0dab5beee9e2ecd84f294 (patch)
tree4f69aac2891547caca4eef3ca107493b8376822b /dev-python/botocore
parentpackage.mask: Last rite dev-python/monotonic (diff)
downloadgentoo-069a8f4f1d2440cb64d0dab5beee9e2ecd84f294.tar.gz
gentoo-069a8f4f1d2440cb64d0dab5beee9e2ecd84f294.tar.bz2
gentoo-069a8f4f1d2440cb64d0dab5beee9e2ecd84f294.zip
dev-python/botocore: Bump to 1.20.49
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.20.49.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5da902d1f8a8..7ca07f4237d3 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -12,3 +12,4 @@ DIST botocore-1.20.45.tar.gz 7597127 BLAKE2B 64023be1da8b10ab29110fe626ba641e9da
DIST botocore-1.20.46.tar.gz 7600596 BLAKE2B 31d81b6ae5ed9a4cf61d81151216bfb49badefce1eb56ae65ead25219044483753e6216883c50602efac336c7d2681a3814ec2449c964d9d0281dc0480180d32 SHA512 fdedd2b79ac8134b7cb819f2f713e7466c4e6f635155799dac0b95b5d97fc2010190b1e64c035b6f375082dff4e65cdf6389e267d25690caa7596dbb381c83c0
DIST botocore-1.20.47.tar.gz 7619450 BLAKE2B c54015bbc537de9a8400f294e3e866f755f462515a2cbde8c15aa80d6d096f02442a71841cb9f9eca931ad948840c94946bcddd58fd1b81ef08d2cba88d9c7c2 SHA512 6f937133e8c9b3978367b4eeeb6b3a752e1d87d528cfc6ee1de8807ad5be14020815c130da25232405a09371a06d329da8b36fb29a0d1ff4391ccfd109727c1a
DIST botocore-1.20.48.tar.gz 7630297 BLAKE2B 63956d3d9aae36ff72b030d33ca182c7af466d3151344ac6b483d8ca661cc18f155b49dc5c4229a8b02b4d9ad2323a91751c6acfc080a09b450f302871e30d0e SHA512 76e38a89aa4faca71a05fe84ed6cade67c5baaabc1ae17ca14b06ffd22a2992bf61e924350945f1a659264c41726fa265aed9ff56d2b3a4e2b726dea717858f7
+DIST botocore-1.20.49.tar.gz 7630973 BLAKE2B 89d10ece5cd645d6904046804c2b2d789d7d09c2aa231856f7b5529f54a4933c2bdcc800a64d3bbc27d9f4a7de7debcb3fbc37ead1923b7fa3dbb44b40dd97e8 SHA512 994f9ee04d0b7c99aee12be5823c29fdafe145b7db71df765ba798ba33650b2189fbbfd274aec1051a7e9be1d1ac0ebf19b61ce4d8afd98635e108bbb2c63351
diff --git a/dev-python/botocore/botocore-1.20.49.ebuild b/dev-python/botocore/botocore-1.20.49.ebuild
new file mode 100644
index 000000000000..4e5d698e619b
--- /dev/null
+++ b/dev-python/botocore/botocore-1.20.49.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+)
+
+distutils_enable_sphinx docs/source \
+ 'dev-python/guzzle_sphinx_theme'
+distutils_enable_tests nose
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+ # very unstable
+ sed -i -e 's:test_stress_test_token_bucket:_&:' \
+ tests/functional/retries/test_bucket.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # note: suites need to be run separately as one of the unit tests
+ # seems to be leaking mocks and breaking a few functional tests
+ nosetests -v tests/unit ||
+ die "unit tests failed under ${EPYTHON}"
+ nosetests -v tests/functional ||
+ die "functional tests failed under ${EPYTHON}"
+}