summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-01 06:30:17 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-01 07:06:12 +0200
commit0cdc38e87a7060cfe8e80519da4d27ea22ca2b4b (patch)
treefe7c19028eee7709a41882759136dc7bc51210a8 /dev-python/botocore
parentdev-python/pandas: unskip byteswap test (diff)
downloadgentoo-0cdc38e87a7060cfe8e80519da4d27ea22ca2b4b.tar.gz
gentoo-0cdc38e87a7060cfe8e80519da4d27ea22ca2b4b.tar.bz2
gentoo-0cdc38e87a7060cfe8e80519da4d27ea22ca2b4b.zip
dev-python/botocore: Bump to 1.31.39
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.39.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index f22cb1dfcefd..47b644756b96 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.31.30.gh.tar.gz 11873788 BLAKE2B 0e0f7500c838c1dc1978956a1b191b30f217ff55ae17a3f601956362b0be2058bf895477db486f532dbb334d925da2ebe7c24c5a8e08585e2c817bb2539b4f3c SHA512 310d5c23ad1ca38550032b9810106fefd5f6431b717c8296bf6e7d208d5c7d1a6b4a97684f2386f4dac27463e1005e08fd67b0e6be07a5c625fa3c8c3a383378
DIST botocore-1.31.35.gh.tar.gz 11877715 BLAKE2B 64c90cb764ab47fdf9f644b4819c9fc1486c07ea2b72b8f2b35fc8adbead5efa7fb43140a2008ca21b63e0981017b366588c6f77e8cb5f5e4acef359f0b0e959 SHA512 63f044f7ac2419d2682a838a35a17d9a1a6a56fa7321e181e959923dbeaf41b5396c96a02eaace7421775c25e4ab63822a5fd57e02d618d4644ecbece72286c2
DIST botocore-1.31.38.gh.tar.gz 11926426 BLAKE2B 1f668a23e52f3033f3b12e6dfeb086d21eb6fd3e163ab12e5c07ccbf4a4a11df9504bac99d6b68a3001f7f1c5849a4d5340ddf5b838b349fc3aed580f6733a03 SHA512 800301dfca0a284d53e252bfbeff9e705120e087c45167bfee8ad343e7873a1eb69d2be725ef8a81bbd7c31fa2016908bfb3729d560d44b36f2ca160aac4663e
+DIST botocore-1.31.39.gh.tar.gz 11927900 BLAKE2B 28b1fe5beea5b586b3bf6434ad3ab32b8f781ae79ddc39a142a53f5e87d136bcad4e1d1baaeee2afc4b09c3e4b02f583817d6471d09dd145b881fafdf71c73e1 SHA512 2dc271ace551ff4c9a25d6ed4c3a31dbdd90cb0f1c4088e1c71b220e20f4b7008fd41b2682c838c5e3fe911c35758a99502fe874c45c51092a83150a14d25edc
diff --git a/dev-python/botocore/botocore-1.31.39.ebuild b/dev-python/botocore/botocore-1.31.39.ebuild
new file mode 100644
index 000000000000..5894fd995097
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.39.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}