summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-07-23 04:49:37 +0200
committerMichał Górny <mgorny@gentoo.org>2024-07-23 04:49:37 +0200
commit4b9acc156cc26399a92f07cb361ee51ec7184fa6 (patch)
treefe3f498906e6458cf1f08a2510bb8708a3549cbd /dev-python/botocore
parentdev-qt/qtconnectivity: skip tst_qbluetoothdevicediscoveryagent (diff)
downloadgentoo-4b9acc156cc26399a92f07cb361ee51ec7184fa6.tar.gz
gentoo-4b9acc156cc26399a92f07cb361ee51ec7184fa6.tar.bz2
gentoo-4b9acc156cc26399a92f07cb361ee51ec7184fa6.zip
dev-python/botocore: Bump to 1.34.146
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.146.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 0aa23781d9b7..85028f0f29bc 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.34.140.gh.tar.gz 13156596 BLAKE2B 4a264fe767c35dcc65ddbe1eb29529d2576553e4d6f9a3d6c28f249aaa0eab5a0fd150fdbdc1dbd1b83cc1fb6fce8f58c68de43f5dc338cb3feb5b9f76c8f973 SHA512 36c90da9670639ccc10e65ced501a2b16e50b664f11be2686f6fcfc56fa81271f160b27b7ffac513446afe09ef6ed4768818ad8b8ca540571737c47fdf980443
DIST botocore-1.34.144.gh.tar.gz 13221134 BLAKE2B 9b688a781ad80f294c147ce4aacc31b59ad90369722a256b934610790682fbe54fcc18bded66d3151c24335dafdcc2eecaa293a30f6715aa69ded57efacd6540 SHA512 92d96253eb62b0425d3763cd9df7f5e944e780c5694b6bad03aa1671b65a5a786b54cad037479f2e227b86b2dd33da1a10db1da1ede857378a9f9783405bb288
DIST botocore-1.34.145.gh.tar.gz 13230154 BLAKE2B ebcf6acdd7ab01bca4032eaa9bc94fd72807edb3b0ce7cdc7addc4bed9a3500627b95d95e69c3027ecb384e65d95c0955e71a0e3262d89e3e8d49eefc37e9aaf SHA512 96042253f2f5ec74b258327c3c4eb322a8ed534ac8ed78f38a5aafb3a97ce832bfe5184090a2dadd41e30b75bf35c463d8d80c3de72a46410656d62076469650
+DIST botocore-1.34.146.gh.tar.gz 13225796 BLAKE2B e59b6192e4fe3e7d0305b43f869049a864909211a3a507a64bca662988c5d982c98f911e272f7928032c7a5b313b7538bd4eaac5f4a43071b5add58c07252c49 SHA512 3032c453bcaac696dfae811880a5ff036ef0f0cd47450d6509aa9f7cd45e6fab043819f73544c4de1b44e59c5e0e8d388c3e99ff9b180912a209d6c1903d737f
diff --git a/dev-python/botocore/botocore-1.34.146.ebuild b/dev-python/botocore/botocore-1.34.146.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.146.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}