summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-09-06 04:02:46 +0200
committerMichał Górny <mgorny@gentoo.org>2024-09-06 11:24:53 +0200
commit4c3f6268224b1846d87ee41242f9e7e02d4b63f7 (patch)
tree4c8349561047b179224cfe710c03d16b052a35a6 /dev-python/botocore
parentgames-board/megamek: drop 0.34.10-r2 (diff)
downloadgentoo-4c3f6268224b1846d87ee41242f9e7e02d4b63f7.tar.gz
gentoo-4c3f6268224b1846d87ee41242f9e7e02d4b63f7.tar.bz2
gentoo-4c3f6268224b1846d87ee41242f9e7e02d4b63f7.zip
dev-python/botocore: Bump to 1.35.13
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.13.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index c4c092d82c0b..fe4fe4510a72 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -2,4 +2,5 @@ DIST botocore-1.35.0.gh.tar.gz 13294975 BLAKE2B a0cbafd1b0da5cd7150ea7a2e21b1209
DIST botocore-1.35.10.gh.tar.gz 13328544 BLAKE2B cecad54696210597a09f4316a88b8335bc441a6429ddbc7f3c6e539a1aaee4312b855ec93b99971c8241b2431a920085f4f3b38545d607609a8d6a94d36676d8 SHA512 cf6bb103aea0af9ed2e43762848438eef89ab5bf8eec856cb8cd70204dd36f143ab9b8defd6ecd849a542332351feb499d8c34e7382bde558eac3ad19b1c5757
DIST botocore-1.35.11.gh.tar.gz 13332112 BLAKE2B fe540370c3f0256788621c96778b8f6d905c6d4e5a435567e09a10af577669ba6196734d9e58c7e61d20d662bcb383d4028dee104a64746406be67526ede428d SHA512 0541ab8eef9793b5e35779f2f97b69d4f55140f4653bf7d07a2973e63fdd09f3ed377b97640e0d7d0c031276b21bc9586799453ef5f5bed8909456498d4c2f20
DIST botocore-1.35.12.gh.tar.gz 13335825 BLAKE2B 2b128dba80061708524eedf33ea636ade8420aaecb9935f697211c369bec710ca6cdcebab105d30c331a03ea360f3085f2377f57fdaeba7576f7bcd09d8b08a8 SHA512 59d9c3c9235ba6b0ebd9dd8d1c10262e07fe7dfd577970eb2621272f74633f0905325c888ec7e4d5f0e10748e6e081ba2b9ed1d12e47d7de90742413f4376784
+DIST botocore-1.35.13.gh.tar.gz 13340405 BLAKE2B da1bca16706cbbe7e80771691c32c85cd6f8dbd22b1e9212cfcecd7673673b9b8c55f76ceb81d7254bafa74939f9629320ca3bf50700e5f1e5ec0dc903bf26c3 SHA512 8e5d9ad5215e8341c007a26288e3dd5fcf1463983ee6f071c597ca9a00887430e173376c8442ea1e7cb0758d3202d4d62464141883a9a692789906046b2209ea
DIST botocore-1.35.5.gh.tar.gz 13303437 BLAKE2B 0a95351fbc93074bb0398871773120a194fe581a26f9a74c1101a5ea57bb3acb9a33937fc2d5a39a065988cdcc6dbe253bd2227cf93e670602ccc67ab82d8845 SHA512 5527420017a4a23d5593f5b3a0eb8caf15357642ed90cd73e0fe22774cc8f9f3637028286063e3e2810e5dafe52e882928269e5c82f6369be9af99bef18fb365
diff --git a/dev-python/botocore/botocore-1.35.13.ebuild b/dev-python/botocore/botocore-1.35.13.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.13.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}