summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick McLean <patrick.mclean@sony.com>2020-05-11 20:08:17 -0700
committerPatrick McLean <chutzpah@gentoo.org>2020-05-11 20:08:17 -0700
commit6d14995e4eb605b83cc830e4e4417b3a40e133b5 (patch)
treef73e005906c57d1fc8375176d6a9580a110be212 /dev-python/botocore
parentnet-misc/openssh-8.2_p1-r6: Fix libressl patch (diff)
downloadgentoo-6d14995e4eb605b83cc830e4e4417b3a40e133b5.tar.gz
gentoo-6d14995e4eb605b83cc830e4e4417b3a40e133b5.tar.bz2
gentoo-6d14995e4eb605b83cc830e4e4417b3a40e133b5.zip
dev-python/botocore-1.16.7: Bump, remove dep version locks
Copyright: Sony Interactive Entertainment Inc. Package-Manager: Portage-2.3.99, Repoman-2.3.22 Signed-off-by: Patrick McLean <chutzpah@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.16.7.ebuild57
-rw-r--r--dev-python/botocore/botocore-9999.ebuild4
-rw-r--r--dev-python/botocore/files/botocore-1.16.7-unlock-deps.patch27
4 files changed, 89 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 5a0e3c32ac30..1258eaa265af 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.15.16.tar.gz 6173930 BLAKE2B 70e185faa9fa3f8537e38e4db8c263f5bfb
DIST botocore-1.15.32.tar.gz 6261957 BLAKE2B 7825e7d6315cae3578155825e0b5cb3961e5548021d63dad1747903c8f55bede03c4fdb0a07b724e2816ef294a890e85a648bae313620ab4156fd2a28d4e517b SHA512 865612fa52aae3bf08ee74b52a3fe685d7308d0d86bd438851e0b9db639ba3f6430211a7863c1b0737c0af0afc6ba760b2ccfd0103d303e87758317f773cef6d
DIST botocore-1.15.48.tar.gz 6336322 BLAKE2B 0d25424e82fcbf1376bb1eb9cac9eeb7a45d08698f39563f635a34b1b24bc6823c5f2b08b6a40a0fc9b54b0404b8f5dd7d07fc21e0c7e0c489fe172e7f29a936 SHA512 91d86731909be5828e38a69e32e5189fbd0357378c51a04f60efbcfbb1b6c0c01151c982fc32619e3be240f5df881e5342bbba6b290b3092d9fe11ce9e3b28d0
DIST botocore-1.16.6.tar.gz 6386032 BLAKE2B e909e2fa021d5b1be333a31758af408cdc6e11224addefac31b87b8ce9983350aeaaf862feaf040490fad8eb87d7dde800bd8a77156410e6a734f567e2cc1055 SHA512 1f265a0a8adb7f0172f02448d3be5aeacf11e3fb7023da8d81e6d19c39d97cac99cfe3a70997e682deb44a4fd78304e4a0c1df43787f3139bbccbe852c682a82
+DIST botocore-1.16.7.tar.gz 6391893 BLAKE2B 19a8770ef1058e5601a1c292e2e17e1625e4d5d0d1845b59bbd403a2c285da1a774935e9d1e1fa7ca26a1e3c4703b29fcbb2f021a7251aa3ca756c80b2ba0461 SHA512 0ab2b4ff4096049cd92b96c710a38867a53b2dba0f07a319ec1a2f9b3cbce60776026c62e3eaaebe571b6ad26eb5c1c258b2dd350a444d30e54b342bcd675768
diff --git a/dev-python/botocore/botocore-1.16.7.ebuild b/dev-python/botocore/botocore-1.16.7.ebuild
new file mode 100644
index 000000000000..be9914c2cdab
--- /dev/null
+++ b/dev-python/botocore/botocore-1.16.7.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_6 python3_7 python3_8 )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3."
+HOMEPAGE="https://github.com/boto/botocore"
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+ KEYWORDS="~amd64 ~arm64 ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jmespath[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch"
+ "${FILESDIR}/botocore-1.16.7-unlock-deps.patch"
+)
+
+distutils_enable_sphinx docs \
+ 'dev-python/guzzle_sphinx_theme'
+
+python_compile_all() {
+ # remove version locked deps
+ sed -r -e 's:([a-zA-Z0-9_-]+)[><|=].*:\1:' \
+ -i requirements.txt || die
+}
+
+python_test() {
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/unit || die "unit tests failed under ${EPYTHON}"
+ PYTHONPATH="${BUILD_DIR}/lib" nosetests -v tests/functional || die "functional tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/botocore/botocore-9999.ebuild b/dev-python/botocore/botocore-9999.ebuild
index f9ce3c85acf8..54136d6d4829 100644
--- a/dev-python/botocore/botocore-9999.ebuild
+++ b/dev-python/botocore/botocore-9999.ebuild
@@ -45,6 +45,10 @@ PATCHES=( "${FILESDIR}/1.8.6-tests-pass-all-env-vars-to-cmd-runner.patch" )
python_compile_all() {
use doc && emake -C docs html
+
+ # remove version locked deps
+ sed -r -e 's:([a-zA-Z0-9_-]+)[><|=].*:\1:' \
+ -i requirements.txt || die
}
python_test() {
diff --git a/dev-python/botocore/files/botocore-1.16.7-unlock-deps.patch b/dev-python/botocore/files/botocore-1.16.7-unlock-deps.patch
new file mode 100644
index 000000000000..1dbb890fbced
--- /dev/null
+++ b/dev-python/botocore/files/botocore-1.16.7-unlock-deps.patch
@@ -0,0 +1,27 @@
+diff --git a/setup.py b/setup.py
+index edc35789..94545b8d 100644
+--- a/setup.py
++++ b/setup.py
+@@ -24,17 +24,17 @@ def find_version(*file_paths):
+
+
+ requires = [
+- 'jmespath>=0.7.1,<1.0.0',
+- 'docutils>=0.10,<0.16',
+- 'python-dateutil>=2.1,<3.0.0',
++ 'jmespath',
++ 'docutils',
++ 'python-dateutil',
+ ]
+
+
+ if sys.version_info[:2] == (3, 4):
+ # urllib3 dropped support for python 3.4 in point release 1.25.8
+- requires.append('urllib3>=1.20,<1.25.8')
++ requires.append('urllib3')
+ else:
+- requires.append('urllib3>=1.20,<1.26')
++ requires.append('urllib3')
+
+
+