summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-03-23 06:41:28 +0100
committerMichał Górny <mgorny@gentoo.org>2024-03-23 07:41:13 +0100
commita420bb3f1305ff139f6e24e4c441d38b88f6ca08 (patch)
treeb1cfed9388f89e436fd98c792c8040dc8af9f7f3 /dev-python/botocore
parentdev-ruby/csv: add 3.3.0 (diff)
downloadgentoo-a420bb3f1305ff139f6e24e4c441d38b88f6ca08.tar.gz
gentoo-a420bb3f1305ff139f6e24e4c441d38b88f6ca08.tar.bz2
gentoo-a420bb3f1305ff139f6e24e4c441d38b88f6ca08.zip
dev-python/botocore: Bump to 1.34.69
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.69.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 155ac36c9b93..b3eaa2b9f9c5 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.34.65.gh.tar.gz 12776587 BLAKE2B c2e54d007e910e5fb274655a0b8fcde
DIST botocore-1.34.66.gh.tar.gz 12780694 BLAKE2B 004e9e2d60c1b62a730cb9718f7f9b849ede23dfe4d08a138406c801de61b3867f78363167f9c49a64a0d604121d893061c068b1e4e0dda282911a428d88d613 SHA512 3731ea08a2868f59839ebdd3a194bc9afdfbc2b5557767846b5a97956ee2a29b454514a5af46dd65ac43ab00ed2d684572b8e3b0599be51349ef52808dc231b8
DIST botocore-1.34.67.gh.tar.gz 12783869 BLAKE2B 762c01fc4f79213ace3f2cfe862db9f14a992fdeb884a6c8d7aeb5096bb74319ff29fc72c50717eb5a9a44eae1a55f226c57909f839f6690553d3dd1d8e2e0eb SHA512 18c1e3c2b57c74a4c61ccb66213f8e1108701abfae384732f6782492d4594bc3e754112ccb4aa26736f641baad4a30ec92a620d34bfcbcfd3ecc002d5a702a25
DIST botocore-1.34.68.gh.tar.gz 12789296 BLAKE2B f8ed1d15f7bccfcba31dc61eb412f71a96344eb60c16ed18e307f63cbdfc621639d0222dd31686bdf1de64c3355bdba9345d861e3ad2904551f39974cff1c08f SHA512 e9bd9d895898da0096be5599a1109b927ed6a4706fd5fd5d82d628d4e92e36ba7864646612dadb60647d10b2cbcb790119d92177eaaebc13aaecb47c2f4a0b32
+DIST botocore-1.34.69.gh.tar.gz 12790282 BLAKE2B 3d12eb5eb8e85777b43b3774e783c907f05e50dfe93445920ee0f42a82857ba7a70c5641e3cbfc03ab05f81f7cd989ff79e332bf2ae192b9bf7b3b3cbe6e9c0e SHA512 b520c5d3c6ce2f1db3e8620e5f7c882ed8483928de1cb32d22eabe76262ed8658614a0b1db42ceff445f11b009c48ef9a5761490e5982154e14173750b9e2554
diff --git a/dev-python/botocore/botocore-1.34.69.ebuild b/dev-python/botocore/botocore-1.34.69.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.69.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}