summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-04-06 06:00:19 +0200
committerMichał Górny <mgorny@gentoo.org>2024-04-06 06:53:16 +0200
commitb6ba21a3055ea320703a110bf1212f53228ecf13 (patch)
tree2a4081c71a1cd281d37bdc4380108c6713639313 /dev-python/botocore
parentnet-vpn/strongswan: Stabilize 5.9.14 arm, #928650 (diff)
downloadgentoo-b6ba21a3055ea320703a110bf1212f53228ecf13.tar.gz
gentoo-b6ba21a3055ea320703a110bf1212f53228ecf13.tar.bz2
gentoo-b6ba21a3055ea320703a110bf1212f53228ecf13.zip
dev-python/botocore: Bump to 1.34.79
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.79.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index eb4eee712072..5a6c8f35f4f3 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.34.75.gh.tar.gz 12864283 BLAKE2B bc5a64b704e1ae4ceebfe65d748e2e9
DIST botocore-1.34.76.gh.tar.gz 12868763 BLAKE2B f6a73414b8ae0dd6628dd55575809461919a2208b57633b34cf3de70712660053040a636d037fb65c4ff37a85ae48e048308935b9e3f8911397b5ba1cccd24bd SHA512 adccbd547f6ac73d1d55f51f9fb3ba8da6ad7ac5e34f3b5c8e50ebaf00893c87762ab44443a0420174816cf5c6ee9a5453cd84deac70b517e72eb5d58e595cb5
DIST botocore-1.34.77.gh.tar.gz 12880716 BLAKE2B a4c1210921147003ca032a16eb2d67df23f7c0b8c5cdccb0eeee9e9adc93758e74560c3d5dc70bd16b69d281cceb62949f6c1c288cd2ee29e0d6b2ecbeb020bd SHA512 caf25f5958790e2b893a7378dfd55204d1dd332dfe346c1efec1d9158ef4aa53a3f214f4926380e424a921fa8561365236ff450ec3726bac054289d824c82c4d
DIST botocore-1.34.78.gh.tar.gz 12882559 BLAKE2B 88d75c9c7e2e7132bdeab5d58b791a3af7c387b90c1e1551cda81eb364d9d177e6e3165c87fa9619731cf95f9d47759edfd22ea5deb9af2a5817a822e91fa4b6 SHA512 95b0b608ea1949092a948dc9aefb452a8db661868360f64e2dd9cf456a0e8b9177309e7d6a12b9e10d4f75bfdfe86ee3bd684f8a15ca0a83dea5fe101ad3953a
+DIST botocore-1.34.79.gh.tar.gz 12882231 BLAKE2B 56d7d2a1046a164f4f64f375f608b8646e0f7c266b1c7ab37ff7141fd8d8d843ce2890b0a947f051956f61fb2cfc75c2eb3b3cf70305de4ba9ce2e18d8569ded SHA512 00717ad582e23e1c4f4d803eea2069224fc69c6e701d6b4a55d0d99806cebfb1e2c45c7eb65464b84e0cc63399a7b6235b90ba9245e27fe435eca6079b5c29aa
diff --git a/dev-python/botocore/botocore-1.34.79.ebuild b/dev-python/botocore/botocore-1.34.79.ebuild
new file mode 100644
index 000000000000..ba6cd2a5d2a2
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.79.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}