summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-01-20 06:41:00 +0100
committerMichał Górny <mgorny@gentoo.org>2024-01-20 06:41:00 +0100
commitbedd396b7f0e0c64400a07e448ea3a978c70ceb1 (patch)
treef2602284dc426dcc31e0126ecaa0cf4f42e7a1fb /dev-python/botocore
parentdev-cpp/xsimd: Remove old (diff)
downloadgentoo-bedd396b7f0e0c64400a07e448ea3a978c70ceb1.tar.gz
gentoo-bedd396b7f0e0c64400a07e448ea3a978c70ceb1.tar.bz2
gentoo-bedd396b7f0e0c64400a07e448ea3a978c70ceb1.zip
dev-python/botocore: Bump to 1.34.23
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.34.23.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 795904492f6b..b2422f3e4b84 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -5,3 +5,4 @@ DIST botocore-1.34.19.gh.tar.gz 12634480 BLAKE2B 839124ae13bd87697bd9d2c4d62f317
DIST botocore-1.34.20.gh.tar.gz 12636646 BLAKE2B 3389ad9e44b529093c26dd7cb48c64b2551237a82218dbc57e4fbe85ae8b97e07f3eb88946fa5108e2d045e58c1e46402e697992b1adfab373eae223f510f1db SHA512 1956b4c090b60e7176ed67f4b80c25305816cb4f22f41a57308daa0748a54720ebc10cd1f620484bbf7d4df6e05259553ef5e1471141db2b1f0192bc2b6219c2
DIST botocore-1.34.21.gh.tar.gz 12638493 BLAKE2B 28f0ffa7f264e56912bf6f68d2d0851b5126c68eb4687fa9dba777bf58f8737fcbc1bc160f158a38aa15b6e03211b32eb3c08e7c1685adcae7159b498dd02fe8 SHA512 5a074f067a7657ce0856b72eaa7334b4c92be0734ac634a00f81dee3ab9b7e5a0bd95b5e93f6189d3d82cd2006bdef9aa9dfae5922d0e89e6c37898dc00784b8
DIST botocore-1.34.22.gh.tar.gz 12643874 BLAKE2B 7b9d375aff7b39cebf7303dec7b0b984a76a7c356431e4c010334a6f31e3d93dd02a9f8809b0857a92aef9c76f85d3db0c21569cbc1b728b67b4be3192082aa5 SHA512 cb26d52db329d4e599fafd300af646335814de2c71f0c385fc3a20c70e5d5a397805fd4627ba08df629f1513015f7bab5ad0211114d3a95a810eff97595a924c
+DIST botocore-1.34.23.gh.tar.gz 12647072 BLAKE2B be20994714a1f31ac5272d5b7be8424e574be1059c5be311e68d1932eb6884a54f71287dc5a9c11996063e4c2ab15a342bf778a0a90620710761e63a5deaa170 SHA512 fcc1879245e8d848c8cd6283af904e0408a5bdaa3b3e14c4ae267735cb29bdde50f1da5f3232ea23053f25fc1f29a1204a08a5c820909cf8667595543b6cfdea
diff --git a/dev-python/botocore/botocore-1.34.23.ebuild b/dev-python/botocore/botocore-1.34.23.ebuild
new file mode 100644
index 000000000000..dcd34e4e67de
--- /dev/null
+++ b/dev-python/botocore/botocore-1.34.23.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}