summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-08-30 04:16:45 +0200
committerMichał Górny <mgorny@gentoo.org>2023-08-30 05:01:39 +0200
commitd46e99cda711a7bd2ed245fc91cb8311e3f827f0 (patch)
tree9345f766c55ba605ce59d3a7a225c094a8f05dee /dev-python/botocore
parentmedia-video/ffmpeg: add missing DEPEND on vulkan-headers (diff)
downloadgentoo-d46e99cda711a7bd2ed245fc91cb8311e3f827f0.tar.gz
gentoo-d46e99cda711a7bd2ed245fc91cb8311e3f827f0.tar.bz2
gentoo-d46e99cda711a7bd2ed245fc91cb8311e3f827f0.zip
dev-python/botocore: Bump to 1.31.37
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.37.ebuild72
2 files changed, 73 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 78c627e55550..66839c3b6d53 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -12,3 +12,4 @@ DIST botocore-1.31.33.gh.tar.gz 11877895 BLAKE2B feec0dc8b6d7db2630ee381a41e7443
DIST botocore-1.31.34.gh.tar.gz 11877457 BLAKE2B 1d92e2b3cbddad824d78e374bec5625b946bb3eb2c262a7eff79ed25e40066bdb17408d9f659ecc8923d544583c21335d8f4032f893eddf4c653064c1bc8c0b3 SHA512 b9fbfb0234cd7fcfd196c1bfa07a01b8583bdf0af425c9f4f27d1bdcc1ca0323c9b78444957f839b6d9c3597c1c60dcb3f32c9263598e555375dd1871d734b8c
DIST botocore-1.31.35.gh.tar.gz 11877715 BLAKE2B 64c90cb764ab47fdf9f644b4819c9fc1486c07ea2b72b8f2b35fc8adbead5efa7fb43140a2008ca21b63e0981017b366588c6f77e8cb5f5e4acef359f0b0e959 SHA512 63f044f7ac2419d2682a838a35a17d9a1a6a56fa7321e181e959923dbeaf41b5396c96a02eaace7421775c25e4ab63822a5fd57e02d618d4644ecbece72286c2
DIST botocore-1.31.36.gh.tar.gz 11879082 BLAKE2B 61f41aef704321e77a7670a4580a1bb18527a953018c87150826990e557658a4d05d47aca4b464a556dd5866cb6cb8a43c033f87a6cb99812ce3cc3dffad2fbd SHA512 b8bf028993c63026b015cbf5248df25055b5d8a52ff153d16c24bddcf957f3abc1c83610da61e5664fe74cf2e7108193a6038339c8b4beb2bacb4686f806aa8c
+DIST botocore-1.31.37.gh.tar.gz 11882688 BLAKE2B af7ff26dc7d1ebe2be86334ec642e89af6069a484834a2b02a4d06fc8d05073421401cc962911b41f859d1f2fa00d38803e2100952af7e4925998c1471fae3c4 SHA512 33982ffb855967b6caf58f9eccb37a9e4857a67b9bd5973339aadc092dd23e82c920759ea8e8df9ce0b3b14ebb10f49aa3f58f5ee666bf61f852c8eb07e72b58
diff --git a/dev-python/botocore/botocore-1.31.37.ebuild b/dev-python/botocore/botocore-1.31.37.ebuild
new file mode 100644
index 000000000000..5894fd995097
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.37.ebuild
@@ -0,0 +1,72 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ # fails on unrelated warnings
+ tests/unit/test_client.py::TestAutoGeneratedClient::test_BOTO_DISABLE_COMMONNAME
+ tests/unit/test_client.py::TestClientErrors::test_BOTO_DISABLE_COMMONNAME
+ # TODO
+ tests/functional/test_credentials.py::SSOSessionTest::test_token_chosen_from_provider
+ )
+
+ epytest tests/{functional,unit} -n "$(makeopts_jobs)"
+}