summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-09-27 07:02:12 +0200
committerMichał Górny <mgorny@gentoo.org>2023-09-27 07:56:24 +0200
commitde4fce097a106a3065c6a6a4cdebc34820ea223e (patch)
tree5a95d695e989ddd92754fe0cc354f95a9bde9736 /dev-python/botocore
parentapp-portage/elogv: Stabilize 0.8.0 x86, #914816 (diff)
downloadgentoo-de4fce097a106a3065c6a6a4cdebc34820ea223e.tar.gz
gentoo-de4fce097a106a3065c6a6a4cdebc34820ea223e.tar.bz2
gentoo-de4fce097a106a3065c6a6a4cdebc34820ea223e.zip
dev-python/botocore: Bump to 1.31.55
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.31.55.ebuild68
2 files changed, 69 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 84ed2c8ce456..2afb93993b45 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -1,3 +1,4 @@
DIST botocore-1.31.49.gh.tar.gz 11946203 BLAKE2B 3b3026f0861705cc3467391c673d2e2f8e63af1a2e52b63cad21e5f75bf31f5970a2a5f5a959dc8dcd1be6c3ad67ed10642c79a7d41a24e15e983096818e8197 SHA512 8e1cb12ff7455bbf62c5cf54c2bc1b8f48484ebc6e95b4e061d5bc6388a4ecd3ff4152a1d9aab5cbee84d872d59417cfb1cecb6fd281f1f8dd9e3e7e04cc782d
DIST botocore-1.31.53.gh.tar.gz 11950545 BLAKE2B 2fef49b98179046203470c6dc145b13a1ff4ddec4eb3ac0bc8f9668b4d7ef9dfdee096f91abb8ede1e1abfffe55f72c9c38c63587b79082a2de7de84e4c9f273 SHA512 2c4d9761ee3cc8b73e60de3388475c64cbd562efd8265a098ba49731751d2c501167d84b010984a0dd738bb1e71a85db6f86aea68c86e9db5ed8613304570529
DIST botocore-1.31.54.gh.tar.gz 11879790 BLAKE2B 8feaab92edaada974af275c81a41d6b36d6444ee1d46718b6c765aacad0450a52bf47fbcccd923f2c442400bea6cc1fb0f2fb8f6a73e3835fd16da38dc609ec4 SHA512 3dfa2212edbc9ed4bc435ec1d4f7aa8b9b9c656cd76feab6c898f57303897ee018120a069bc477fb8700111908ecaf6465229d67e6b6c5c777369b224d00c01d
+DIST botocore-1.31.55.gh.tar.gz 11883762 BLAKE2B eac01a2c463754306f2846ed914453114044b8ef0e94848d2bf0f59e01324bf8c7c366976722de7a791f482e891f005dc2f6ac4a1f3adfad92100d452b6bb3db SHA512 14bc1a6b12fd2bf08fa881f2265d1b0057c16b5001991278f07590f8f09b3237cf182a583f93a657d74c420179f0eee689debd192c254787aa8cb3fc17c79348
diff --git a/dev-python/botocore/botocore-1.31.55.ebuild b/dev-python/botocore/botocore-1.31.55.ebuild
new file mode 100644
index 000000000000..7cacb5c3f634
--- /dev/null
+++ b/dev-python/botocore/botocore-1.31.55.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 multiprocessing
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+LICENSE="Apache-2.0"
+SLOT="0"
+
+if [[ "${PV}" == "9999" ]]; then
+ EGIT_REPO_URI="https://github.com/boto/botocore"
+ inherit git-r3
+else
+ SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ "
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+fi
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ local -x EPYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit} -p xdist -n "$(makeopts_jobs)"
+}