summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-29 05:45:24 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-29 06:21:11 +0200
commite2832e030b347d0ae4ee616e079b700fd7365d97 (patch)
tree8eda2496a324bda2c1d4949f9581ef23cf6f5f5d /dev-python/botocore
parentsec-keys/openpgp-keys-gentoo-developers: Stabilize 20240708 ALLARCHES, #938652 (diff)
downloadgentoo-e2832e030b347d0ae4ee616e079b700fd7365d97.tar.gz
gentoo-e2832e030b347d0ae4ee616e079b700fd7365d97.tar.bz2
gentoo-e2832e030b347d0ae4ee616e079b700fd7365d97.zip
dev-python/botocore: Bump to 1.35.8
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/botocore')
-rw-r--r--dev-python/botocore/Manifest1
-rw-r--r--dev-python/botocore/botocore-1.35.8.ebuild76
2 files changed, 77 insertions, 0 deletions
diff --git a/dev-python/botocore/Manifest b/dev-python/botocore/Manifest
index 15edec15d263..dd7977494055 100644
--- a/dev-python/botocore/Manifest
+++ b/dev-python/botocore/Manifest
@@ -3,3 +3,4 @@ DIST botocore-1.35.0.gh.tar.gz 13294975 BLAKE2B a0cbafd1b0da5cd7150ea7a2e21b1209
DIST botocore-1.35.5.gh.tar.gz 13303437 BLAKE2B 0a95351fbc93074bb0398871773120a194fe581a26f9a74c1101a5ea57bb3acb9a33937fc2d5a39a065988cdcc6dbe253bd2227cf93e670602ccc67ab82d8845 SHA512 5527420017a4a23d5593f5b3a0eb8caf15357642ed90cd73e0fe22774cc8f9f3637028286063e3e2810e5dafe52e882928269e5c82f6369be9af99bef18fb365
DIST botocore-1.35.6.gh.tar.gz 13305231 BLAKE2B 1c3716883b2cc8dd98e4391ff60039f14e0e0fcd076a3780b6ee18c216f004d6f1ed2e916681d28133ae9788fd5c721abbba6c44354442a6d7862074e7f8956a SHA512 6d2ab4264886e231cb0b65ea34d2757b29ba71fe227bf8dbff3474074d612f13b3e9fcfe17b9cb2f8f420bd962f1eefe7b8038ef5017060c6732ec5ed927906e
DIST botocore-1.35.7.gh.tar.gz 13308318 BLAKE2B 4e92e22dde9a4b414a1cace9a21f8a536a0f386dd4b14bd594dc08dff3d05e8aa17c669222b07617db8b883ec79ab48a18d669619ff14400c09df26c0d3101fe SHA512 5188b485db0db1fdaf51ae1ff5c57caa114d0f08b04ef20cd821b5b13b661374dc4463694cf027c1ac25f903ea74be81464d0041c856e93315781398cfde611c
+DIST botocore-1.35.8.gh.tar.gz 13321226 BLAKE2B d4808db439d9fd6be7d759d7785b788269688a288d458e37f718ddbb23f92df92113f6d8cbe44b07c8be92f6a4ac8fa5951a58d68513c8ade02355731ed9696d SHA512 a9c38c7fcb89da6164aef60f47c9882730f613f3d05ffbaeedab7167d730b80670e43288bf66dbade46829c0ef9171a7141b4ba6332937dcff29fc06a78413b1
diff --git a/dev-python/botocore/botocore-1.35.8.ebuild b/dev-python/botocore/botocore-1.35.8.ebuild
new file mode 100644
index 000000000000..4f1ad852bdc1
--- /dev/null
+++ b/dev-python/botocore/botocore-1.35.8.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..13} )
+
+inherit distutils-r1
+
+DESCRIPTION="Low-level, data-driven core of boto 3"
+HOMEPAGE="
+ https://github.com/boto/botocore/
+ https://pypi.org/project/botocore/
+"
+SRC_URI="
+ https://github.com/boto/botocore/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ <dev-python/jmespath-2[${PYTHON_USEDEP}]
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ >=dev-python/urllib3-1.25.4[${PYTHON_USEDEP}]
+"
+# unbundled packages
+RDEPEND+="
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ )
+"
+
+EPYTEST_XDIST=1
+distutils_enable_tests pytest
+
+src_prepare() {
+ # unpin deps
+ sed -i -e "s:>=.*':':" setup.py || die
+
+ # unbundle deps
+ rm -r botocore/vendored || die
+ find -name '*.py' -exec sed -i \
+ -e 's:from botocore[.]vendored import:import:' \
+ -e 's:from botocore[.]vendored[.]:from :' \
+ {} + || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ # rely on bundled six
+ tests/functional/test_six_imports.py::test_no_bare_six_imports
+ tests/functional/test_six_threading.py::test_six_thread_safety
+ )
+
+ case ${EPYTHON} in
+ python3.13)
+ EPYTEST_DESELECT+=(
+ # memory use tests, probably fragile
+ tests/functional/leak/test_resource_leaks.py::TestDoesNotLeakMemory
+ )
+ ;;
+ esac
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest tests/{functional,unit}
+}