summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/bytecodeassembler
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/bytecodeassembler')
-rw-r--r--dev-python/bytecodeassembler/Manifest1
-rw-r--r--dev-python/bytecodeassembler/bytecodeassembler-0.6.ebuild31
-rw-r--r--dev-python/bytecodeassembler/metadata.xml8
3 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/bytecodeassembler/Manifest b/dev-python/bytecodeassembler/Manifest
new file mode 100644
index 000000000000..66bdc9d8c89f
--- /dev/null
+++ b/dev-python/bytecodeassembler/Manifest
@@ -0,0 +1 @@
+DIST bytecodeassembler-0.6.zip 52734 SHA256 05d56f7ed3eb7c85912380c31bfe3622063176418d63d5bbd74ce99e5456ae0f SHA512 95f90a1b6e1a307d8754eea301ae187783460fa8df3163f26253b8ebec16b31a8899a1d27c13158c5cb97763c7057f83b1dc1f642b5e2e9e5b844837a5208363 WHIRLPOOL 8d41029dc6a8aecfbe2faec72a3e0e70a279a96d5994a658e9d1a8514f8edf8987cad2a32b80d414d5b09c090e74b2ab1e36ce4e03f0f66cb664466b83a71b0e
diff --git a/dev-python/bytecodeassembler/bytecodeassembler-0.6.ebuild b/dev-python/bytecodeassembler/bytecodeassembler-0.6.ebuild
new file mode 100644
index 000000000000..afc9705b25ed
--- /dev/null
+++ b/dev-python/bytecodeassembler/bytecodeassembler-0.6.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 pypy )
+
+inherit distutils-r1
+
+MY_PN="BytecodeAssembler"
+
+DESCRIPTION="Generate Python code objects by "assembling" bytecode"
+HOMEPAGE="http://pypi.python.org/pypi//BytecodeAssembler"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.zip -> ${P}.zip"
+
+KEYWORDS="amd64 x86"
+IUSE=""
+LICENSE="Apache-2.0"
+SLOT="0"
+
+RDEPEND=""
+DEPEND="app-arch/unzip
+ >=dev-python/symboltype-1.0[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}"/${MY_PN}-${PV}
+
+python_test() {
+ "${PYTHON}" test_assembler.py && einfo "Tests passed under ${EPYTHON}" \
+ || die "Tests failed under ${EPYTHON}"
+}
diff --git a/dev-python/bytecodeassembler/metadata.xml b/dev-python/bytecodeassembler/metadata.xml
new file mode 100644
index 000000000000..940caaebe748
--- /dev/null
+++ b/dev-python/bytecodeassembler/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">BytecodeAssembler</remote-id>
+ </upstream>
+</pkgmetadata>