summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArthur Zamarin <arthurzam@gentoo.org>2022-04-01 10:07:24 +0300
committerArthur Zamarin <arthurzam@gentoo.org>2022-04-01 10:07:24 +0300
commit0f740649e06de3d7b326570dfbd4ad7a3be0a841 (patch)
treee7f3dbf76f428644d56ce9abfdb7bf4d65f19395 /dev-python/click/click-8.1.2.ebuild
parentsys-devel/gcc: Stabilize 10.3.1_p20211126 ppc64, #833358 (diff)
downloadgentoo-0f740649e06de3d7b326570dfbd4ad7a3be0a841.tar.gz
gentoo-0f740649e06de3d7b326570dfbd4ad7a3be0a841.tar.bz2
gentoo-0f740649e06de3d7b326570dfbd4ad7a3be0a841.zip
dev-python/click: add 8.1.2
Signed-off-by: Arthur Zamarin <arthurzam@gentoo.org>
Diffstat (limited to 'dev-python/click/click-8.1.2.ebuild')
-rw-r--r--dev-python/click/click-8.1.2.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/click/click-8.1.2.ebuild b/dev-python/click/click-8.1.2.ebuild
new file mode 100644
index 000000000000..ba8f4b9c8fe8
--- /dev/null
+++ b/dev-python/click/click-8.1.2.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python package for creating beautiful command line interfaces"
+HOMEPAGE="
+ https://palletsprojects.com/p/click/
+ https://pypi.org/project/click/
+"
+SRC_URI="
+ https://github.com/pallets/${PN}/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+IUSE="examples"
+
+distutils_enable_sphinx docs \
+ '>=dev-python/docutils-0.14' \
+ dev-python/pallets-sphinx-themes \
+ dev-python/sphinxcontrib-log_cabinet \
+ dev-python/sphinx-issues
+distutils_enable_tests pytest
+
+python_install_all() {
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}