summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-26 22:32:48 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-26 22:52:55 +0100
commit5300a3070a171b2d969c860851609fdb14a77446 (patch)
treec10f91c1a221323a1ac3b8ea5872afbd6edfa181 /dev-python/confuse
parentnet-print/hplip-plugin: Version bump to 3.21.12 (diff)
downloadgentoo-5300a3070a171b2d969c860851609fdb14a77446.tar.gz
gentoo-5300a3070a171b2d969c860851609fdb14a77446.tar.bz2
gentoo-5300a3070a171b2d969c860851609fdb14a77446.zip
dev-python/confuse: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/confuse')
-rw-r--r--dev-python/confuse/confuse-1.7.0-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/confuse/confuse-1.7.0-r1.ebuild b/dev-python/confuse/confuse-1.7.0-r1.ebuild
new file mode 100644
index 000000000000..e0d66868bacb
--- /dev/null
+++ b/dev-python/confuse/confuse-1.7.0-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_PEP517=flit
+
+inherit distutils-r1
+
+DESCRIPTION="Confuse is a configuration library for Python that uses YAML"
+HOMEPAGE="https://github.com/beetbox/confuse"
+SRC_URI="https://github.com/beetbox/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs \
+ 'dev-python/sphinx_rtd_theme'