summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-11-27 21:16:49 +0100
committerMichał Górny <mgorny@gentoo.org>2021-11-27 22:18:24 +0100
commit90656cd209e47d06604f32797406b7103718fcaf (patch)
tree6856a423853111f41ba9b823fa886754b1770bba /dev-python/confuse
parentdev-python/mediafile: Bump to 0.9.0 (diff)
downloadgentoo-90656cd209e47d06604f32797406b7103718fcaf.tar.gz
gentoo-90656cd209e47d06604f32797406b7103718fcaf.tar.bz2
gentoo-90656cd209e47d06604f32797406b7103718fcaf.zip
dev-python/confuse: Bump to 1.7.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/confuse')
-rw-r--r--dev-python/confuse/Manifest1
-rw-r--r--dev-python/confuse/confuse-1.7.0.ebuild24
2 files changed, 25 insertions, 0 deletions
diff --git a/dev-python/confuse/Manifest b/dev-python/confuse/Manifest
index 38508c606217..372087913c73 100644
--- a/dev-python/confuse/Manifest
+++ b/dev-python/confuse/Manifest
@@ -1 +1,2 @@
DIST confuse-1.6.0.tar.gz 44438 BLAKE2B 0a528cfa2a83cb8ffc47017d61571770a9486585308f5e42531ba1f6356f76b385517a4f3319d3365cd5df41ca49578559fb1ba47edd936d6114fc00a816c736 SHA512 e756771dd93987f9c4ba900a2d95b5d87e99b97789810f2f70aec1fe68a919bd11aff815ca0967b8073ad034ed9b927e55599f5fac590822a7897161869da89b
+DIST confuse-1.7.0.tar.gz 49171 BLAKE2B f102ed445d4fc259739305f745fea6c1fef90fe4d8eb7b77bb6c370d37929807478df86ad78ffc8fc2fb1d4cd7033d76e34d880d6dab6721b5fd6cc0e7f5d02a SHA512 0da6cb237aa31f63cf6d2df2e90eb27e7b1a81bd126546a4314425b9dc1d9f993232b4787815abaf7ef4b54ef03ac3286c321e6654fdf18f05f92aa69c3da78e
diff --git a/dev-python/confuse/confuse-1.7.0.ebuild b/dev-python/confuse/confuse-1.7.0.ebuild
new file mode 100644
index 000000000000..b55f3d873523
--- /dev/null
+++ b/dev-python/confuse/confuse-1.7.0.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+inherit distutils-r1
+
+DESCRIPTION="Confuse is a configuration library for Python that uses YAML"
+HOMEPAGE="https://github.com/beetbox/confuse"
+SRC_URI="https://github.com/beetbox/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests unittest
+distutils_enable_sphinx docs \
+ 'dev-python/sphinx_rtd_theme'