summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2024-08-24 21:18:12 +0200
committerMichał Górny <mgorny@gentoo.org>2024-08-24 21:32:31 +0200
commit4c6b931b1f1e95a846fcdd75fcb5971b81948f23 (patch)
tree9140657e8abfd7cedd46eaad41004ff7d1f1cd01 /dev-python/crc32c
parentdev-python/spyder-kernels: drop 3.0.0_beta8 (diff)
downloadgentoo-4c6b931b1f1e95a846fcdd75fcb5971b81948f23.tar.gz
gentoo-4c6b931b1f1e95a846fcdd75fcb5971b81948f23.tar.bz2
gentoo-4c6b931b1f1e95a846fcdd75fcb5971b81948f23.zip
dev-python/crc32c: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/crc32c')
-rw-r--r--dev-python/crc32c/Manifest2
-rw-r--r--dev-python/crc32c/crc32c-2.4.1.ebuild46
-rw-r--r--dev-python/crc32c/crc32c-2.5.ebuild46
3 files changed, 0 insertions, 94 deletions
diff --git a/dev-python/crc32c/Manifest b/dev-python/crc32c/Manifest
index 6aabad8ac867..d448fd9abcb4 100644
--- a/dev-python/crc32c/Manifest
+++ b/dev-python/crc32c/Manifest
@@ -1,3 +1 @@
-DIST crc32c-2.4.1.tar.gz 38277 BLAKE2B 3d4a0eeb5811e8bc46df30b8890ab409de92dc3cfe2c5c3ab355df3394e56812c19ac26523be2cf9c33bb5825fb6e080b6f27ea77bed5c38d98fbe6c247653fb SHA512 005f95f66e97f552a83b5c94b706224f44280895d70c348fee86943bf1589a94b57eeddde5e18499fea9c77cbcbcfd5691d9d4b33ed788dc885a1333b6db476b
-DIST crc32c-2.5.tar.gz 41514 BLAKE2B a9424ef917f3c89f3b8b3881ccd5d59cb8a634d6177260ce9e7300e151e68e97e55b74448dd4cd545d2d66d2e2d8e70a085578719f768662542e43f06e914d20 SHA512 446f2290706eae8a625590c6b314d8422938dd9b8bffcf5e4dd6d3d260932548dbc5d9a9b6e7e5eaaaaac8dce424876f4e4acc9b0b1ea2b7cdc6ddd101228cfd
DIST crc32c-2.6.tar.gz 42985 BLAKE2B 0193b26a56c6a2ec071231815cfcdf8ab3ce58de98e2948ab68c8ccd5779772923c8fd1464c70376ade8d4a6a38a575f8330791b7cda8de82d001a869b22e7e2 SHA512 7ca2614994b558c0f9b12fb743b0dadcfd6e6e3ab71c7550fd892324a91a90816b2dadf9c9946078e0ee2cd4abe14fdca385421bcd9468e41fd656a080b4d52e
diff --git a/dev-python/crc32c/crc32c-2.4.1.ebuild b/dev-python/crc32c/crc32c-2.4.1.ebuild
deleted file mode 100644
index 73c73f15b871..000000000000
--- a/dev-python/crc32c/crc32c-2.4.1.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="CRC32c algorithm in hardware and software"
-HOMEPAGE="
- https://github.com/ICRAR/crc32c/
- https://pypi.org/project/crc32c/
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86"
-# NB: these don't affect the build, they are only used for tests
-IUSE="cpu_flags_arm_crc32 cpu_flags_x86_sse4_2"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x CRC32C_SW_MODE
-
- # force = run "software" code (i.e. unoptimized)
- # none = run "hardware" code (i.e. SSE4.2 / ARMv8 CRC32)
- for CRC32C_SW_MODE in none force; do
- if [[ ${CRC32C_SW_MODE} == none ]]; then
- if ! use cpu_flags_arm_crc32 && ! use cpu_flags_x86_sse4_2; then
- continue
- fi
-
- # the test suite just skips all tests, so double-check
- "${EPYTHON}" -c "import crc32c" ||
- die "Importing crc32c failed (accelerated code path broken?)"
- fi
-
- einfo "Testing with CRC32C_SW_MODE=${CRC32C_SW_MODE}"
- epytest
- done
-}
diff --git a/dev-python/crc32c/crc32c-2.5.ebuild b/dev-python/crc32c/crc32c-2.5.ebuild
deleted file mode 100644
index 73c73f15b871..000000000000
--- a/dev-python/crc32c/crc32c-2.5.ebuild
+++ /dev/null
@@ -1,46 +0,0 @@
-# Copyright 2024 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_EXT=1
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( pypy3 python3_{10..13} )
-
-inherit distutils-r1 pypi
-
-DESCRIPTION="CRC32c algorithm in hardware and software"
-HOMEPAGE="
- https://github.com/ICRAR/crc32c/
- https://pypi.org/project/crc32c/
-"
-
-LICENSE="LGPL-2.1+"
-SLOT="0"
-KEYWORDS="~amd64 ~arm ~arm64 ~riscv ~sparc ~x86"
-# NB: these don't affect the build, they are only used for tests
-IUSE="cpu_flags_arm_crc32 cpu_flags_x86_sse4_2"
-
-distutils_enable_tests pytest
-
-python_test() {
- local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
- local -x CRC32C_SW_MODE
-
- # force = run "software" code (i.e. unoptimized)
- # none = run "hardware" code (i.e. SSE4.2 / ARMv8 CRC32)
- for CRC32C_SW_MODE in none force; do
- if [[ ${CRC32C_SW_MODE} == none ]]; then
- if ! use cpu_flags_arm_crc32 && ! use cpu_flags_x86_sse4_2; then
- continue
- fi
-
- # the test suite just skips all tests, so double-check
- "${EPYTHON}" -c "import crc32c" ||
- die "Importing crc32c failed (accelerated code path broken?)"
- fi
-
- einfo "Testing with CRC32C_SW_MODE=${CRC32C_SW_MODE}"
- epytest
- done
-}